summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2018-08-03 16:04:07 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2018-08-03 16:05:07 +0300
commit54cd339b91bc2008c8d21797a5f7e1daac12b160 (patch)
tree60b0894a0e0f49ef454465191f93feb6f8c5ffe4 /media-sound/apulse/apulse-0.1.12.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.9.117 (diff)
downloadgentoo-54cd339b91bc2008c8d21797a5f7e1daac12b160.tar.gz
gentoo-54cd339b91bc2008c8d21797a5f7e1daac12b160.tar.bz2
gentoo-54cd339b91bc2008c8d21797a5f7e1daac12b160.zip
media-sound/apulse: version bump
- Update to 0.1.12. - Add test support. - Optionally install PulseAudio headers. Fixes: https://bugs.gentoo.org/646740 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'media-sound/apulse/apulse-0.1.12.ebuild')
-rw-r--r--media-sound/apulse/apulse-0.1.12.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/apulse/apulse-0.1.12.ebuild b/media-sound/apulse/apulse-0.1.12.ebuild
new file mode 100644
index 000000000000..1f223fb6cfc4
--- /dev/null
+++ b/media-sound/apulse/apulse-0.1.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib cmake-multilib
+
+DESCRIPTION="PulseAudio emulation for ALSA"
+HOMEPAGE="https://github.com/i-rinat/apulse"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+pa-headers test"
+
+DEPEND="dev-libs/glib:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ pa-headers? ( !media-sound/pulseaudio ) "
+RDEPEND="${DEPEND}
+ !!media-plugins/alsa-plugins[pulseaudio]"
+
+MULTILIB_CHOST_TOOLS=( /usr/bin/apulse )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Ensure all relevant libdirs are added, to support all ABIs
+ DIRS=
+ _add_dir() { DIRS="${EPREFIX}/usr/$(get_libdir)/apulse${DIRS:+:${DIRS}}"; }
+ multilib_foreach_abi _add_dir
+ sed -e "s#@@DIRS@@#${DIRS}#g" "${FILESDIR}"/apulse > "${T}"/apulse || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=("-DAPULSEPATH=${EPREFIX}/usr/$(get_libdir)/apulse")
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ cmake-utils_src_install
+ einstalldocs
+ dobin "${T}"/apulse
+ use pa-headers && doheader -r 3rdparty/pulseaudio-headers/pulse
+}