summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ardour/ardour-4.0-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ardour/ardour-4.0-r2.ebuild')
-rw-r--r--media-sound/ardour/ardour-4.0-r2.ebuild140
1 files changed, 140 insertions, 0 deletions
diff --git a/media-sound/ardour/ardour-4.0-r2.ebuild b/media-sound/ardour/ardour-4.0-r2.ebuild
new file mode 100644
index 000000000000..225267ba04cc
--- /dev/null
+++ b/media-sound/ardour/ardour-4.0-r2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils toolchain-funcs flag-o-matic python-any-r1 waf-utils
+
+DESCRIPTION="Digital Audio Workstation"
+HOMEPAGE="http://ardour.org/"
+
+if [ ${PV} = 9999 ]; then
+ KEYWORDS=""
+ EGIT_REPO_URI="http://git.ardour.org/ardour/ardour.git"
+ inherit git-2
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/Ardour/ardour/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="altivec doc jack lv2 cpu_flags_x86_sse"
+
+RDEPEND="media-libs/aubio
+ media-libs/liblo
+ sci-libs/fftw:3.0
+ media-libs/freetype:2
+ >=dev-libs/glib-2.10.1:2
+ >=dev-cpp/glibmm-2.32.0
+ >=x11-libs/gtk+-2.8.1:2
+ >=dev-libs/libxml2-2.6:2
+ >=media-libs/libsndfile-1.0.18
+ >=media-libs/libsamplerate-0.1
+ >=media-libs/rubberband-1.6.0
+ >=media-libs/libsoundtouch-1.6.0
+ media-libs/flac
+ media-libs/raptor:2
+ >=media-libs/liblrdf-0.4.0-r20
+ >=gnome-base/libgnomecanvas-2
+ media-libs/vamp-plugin-sdk
+ dev-libs/libxslt
+ dev-libs/libsigc++:2
+ >=dev-cpp/gtkmm-2.16:2.4
+ >=dev-cpp/libgnomecanvasmm-2.26:2.6
+ media-libs/alsa-lib
+ x11-libs/pango
+ x11-libs/cairo
+ media-libs/libart_lgpl
+ virtual/libusb:0
+ dev-libs/boost
+ >=media-libs/taglib-1.7
+ net-misc/curl
+ jack? ( >=media-sound/jack-audio-connection-kit-0.120 )
+ lv2? (
+ >=media-libs/slv2-0.6.1
+ media-libs/lilv
+ media-libs/sratom
+ dev-libs/sord
+ >=media-libs/suil-0.6.10
+ >=media-libs/lv2-1.4.0
+ )"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ >=media-sound/jack-audio-connection-kit-0.120
+ sys-devel/gettext
+ doc? ( app-doc/doxygen[dot] )"
+ if ! [ ${PV} = 9999 ]; then
+ DEPEND="${DEPEND}"
+ fi
+
+src_unpack() {
+ if [ ${PV} = 9999 ]; then
+ git-2_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare(){
+ if ! [ ${PV} = 9999 ]; then
+ epatch "${FILESDIR}"/${PN}-4.0-revision-naming.patch
+ touch "${S}/libs/ardour/revision.cc"
+ fi
+ $(use lv2 || epatch "${FILESDIR}"/${PN}-4.0-lv2.patch)
+ epatch "${FILESDIR}"/${PN}-3.5.403-sse.patch
+ sed -e 's/'FLAGS\'\,\ compiler_flags'/'FLAGS\'\,\ program_flags'/g' -i "${S}"/wscript
+ sed -e 's/'compiler_flags.append\ \(\'-DPROGRAM_'/'program_flags.append\ \(\'-DPROGRAM_'/g' -i "${S}"/wscript
+ sed -e '/compiler_flags\ \=\ \[\]/a \ \ \ \ program_flags\ \=\ \[\]' -i "${S}"/wscript
+ append-flags "-lboost_system"
+}
+
+src_configure() {
+ if use cpu_flags_x86_sse; then
+ MARCH=$(get-flag march)
+ for ARCHWOSSE in i686 i486; do
+ if [[ ${MARCH} = ${ARCHWOSSE} ]]; then
+ for SSEOPT in -msse -msse2 -msse3 -mssse3 -msse4 -msse4.1 -msse4.2; do
+ is-flag ${SSEOPT} && SSEON="yes"
+ done
+ if [ -z ${SSEON} ]; then
+ append-flags -msse
+ elog "You enabled sse but use an march that does not support sse!"
+ elog "We add -msse to the cflags now, but please consider switching your march in make.conf!"
+ fi
+ fi
+ done
+ fi
+ tc-export CC CXX
+ mkdir -p "${D}"
+ waf-utils_src_configure \
+ --destdir="${D}" \
+ --prefix=/usr \
+ --configdir=/etc \
+ --optimize \
+ --no-jack-metadata \
+ --nls \
+ $(use jack && echo "--with-backends=alsa,jack" || echo "--with-backends=alsa --no-jack --libjack=weak") \
+ $(use lv2 && echo "--lv2" || echo "--no-lv2") \
+ $({ use altivec || use cpu_flags_x86_sse; } && echo "--fpu-optimization" || echo "--no-fpu-optimization") \
+ $(use doc && echo "--docs")
+}
+
+src_install() {
+ waf-utils_src_install
+ mv ${PN}.1 ${PN}${SLOT}.1
+ doman ${PN}${SLOT}.1
+ newicon icons/icon/ardour_icon_mac.png ${PN}${SLOT}.png
+ make_desktop_entry ardour4 ardour4 ardour4 AudioVideo
+}
+
+pkg_postinst() {
+ elog "If you are using Ardour and want to keep its development alive"
+ elog "then please consider to do a donation upstream at ardour.org. Thanks!"
+}