summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:24:23 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:01 -0400
commit82f98f3eb4a4b2ed283a1eb4701d9119ba6eb655 (patch)
treeffe4718907e6b611813a954bb28c04a1ac22b6e2 /media-sound/aseqview
parentmedia-radio/ibp: pass -std=gnu89 (diff)
downloadgentoo-82f98f3eb4a4b2ed283a1eb4701d9119ba6eb655.tar.gz
gentoo-82f98f3eb4a4b2ed283a1eb4701d9119ba6eb655.tar.bz2
gentoo-82f98f3eb4a4b2ed283a1eb4701d9119ba6eb655.zip
media-sound/aseqview: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-sound/aseqview')
-rw-r--r--media-sound/aseqview/aseqview-0.2.8-r2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/media-sound/aseqview/aseqview-0.2.8-r2.ebuild b/media-sound/aseqview/aseqview-0.2.8-r2.ebuild
index c4eb2a760776..7a010657ef28 100644
--- a/media-sound/aseqview/aseqview-0.2.8-r2.ebuild
+++ b/media-sound/aseqview/aseqview-0.2.8-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="ALSA sequencer event viewer/filter"
HOMEPAGE="https://github.com/tiwai/aseqview"
SRC_URI="https://ftp.suse.com/pub/people/tiwai/${PN}/${P}.tar.gz"
@@ -23,5 +25,7 @@ PATCHES=(
)
src_configure() {
+ append-cflags -std=gnu89 # old codebase, and configure fails with c2x
+
econf --disable-alsatest --disable-gtktest --enable-gtk2
}