summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-14 21:08:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-15 01:34:42 +0100
commit74da6ad0fd38f7c9e62db4820af0d2640b14670a (patch)
treea6c0b3002765b5d24464c6983e4d1b0f695b9acf /media-sound/audacious/audacious-9999.ebuild
parentsci-mathematics/petsc: more configuration fixes (diff)
downloadgentoo-74da6ad0fd38f7c9e62db4820af0d2640b14670a.tar.gz
gentoo-74da6ad0fd38f7c9e62db4820af0d2640b14670a.tar.bz2
gentoo-74da6ad0fd38f7c9e62db4820af0d2640b14670a.zip
media-sound/audacious: Default switched to Qt5
Upstream commit 72e6f21e3a77a18ecfa57120a607a48c4e66b493 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/audacious/audacious-9999.ebuild')
-rw-r--r--media-sound/audacious/audacious-9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/media-sound/audacious/audacious-9999.ebuild b/media-sound/audacious/audacious-9999.ebuild
index 12769bfaa102..edf35f502de2 100644
--- a/media-sound/audacious/audacious-9999.ebuild
+++ b/media-sound/audacious/audacious-9999.ebuild
@@ -20,7 +20,7 @@ SRC_URI+=" mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
-IUSE="nls qt5"
+IUSE="gtk nls"
BDEPEND="
virtual/pkgconfig
@@ -32,8 +32,8 @@ DEPEND="
>=x11-libs/cairo-1.2.6
>=x11-libs/pango-1.8.0
virtual/freedesktop-icon-theme
- !qt5? ( x11-libs/gtk+:2 )
- qt5? (
+ gtk? ( x11-libs/gtk+:2 )
+ !gtk? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
@@ -63,12 +63,14 @@ src_configure() {
# Building without D-Bus is *unsupported* and a USE-flag
# will not be added due to the bug reports that will result.
# Bugs #197894, #199069, #207330, #208606
- econf \
- --disable-valgrind \
- --enable-dbus \
- $(use_enable nls) \
- $(use_enable !qt5 gtk) \
- $(use_enable qt5 qt)
+ local myeconfargs=(
+ --disable-valgrind
+ --enable-dbus
+ $(use_enable gtk gtk)
+ $(use_enable !gtk qt)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {