summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-08-28 09:43:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-28 09:44:43 +0200
commite6b9364ffd66913edfbf0276653a7f881ca4bde6 (patch)
treecf01c2b27b90bb160dece92d3479568fb9676652 /media-sound/audacity/audacity-2.3.2.ebuild
parentdev-ruby/rmagick: stable 3.1.0 for ppc64, bug #688194 (diff)
downloadgentoo-e6b9364ffd66913edfbf0276653a7f881ca4bde6.tar.gz
gentoo-e6b9364ffd66913edfbf0276653a7f881ca4bde6.tar.bz2
gentoo-e6b9364ffd66913edfbf0276653a7f881ca4bde6.zip
media-sound/audacity: Bump to version 2.3.2
Closes: https://bugs.gentoo.org/680028 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound/audacity/audacity-2.3.2.ebuild')
-rw-r--r--media-sound/audacity/audacity-2.3.2.ebuild141
1 files changed, 141 insertions, 0 deletions
diff --git a/media-sound/audacity/audacity-2.3.2.ebuild b/media-sound/audacity/audacity-2.3.2.ebuild
new file mode 100644
index 000000000000..1f561978a5fe
--- /dev/null
+++ b/media-sound/audacity/audacity-2.3.2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic wxwidgets xdg
+
+MY_P="Audacity-${PV}"
+DOC_PV="${PV}"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="https://web.audacityteam.org/"
+# wget doesn't seem to work on FossHub links, so we mirror
+SRC_URI="https://github.com/audacity/audacity/archive/${MY_P}.tar.gz
+ doc? ( https://dev.gentoo.org/~polynomial-c/dist/${PN}-manual-${DOC_PV}.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="alsa cpu_flags_x86_sse doc ffmpeg +flac id3tag jack +ladspa +lame libav
+ +lv2 mad midi nls +portmixer sbsms +soundtouch twolame vamp +vorbis +vst"
+
+RESTRICT="test"
+
+RDEPEND=">=app-arch/zip-2.3
+ dev-libs/expat
+ >=media-libs/libsndfile-1.0.0
+ >=media-libs/portaudio-19.06.00-r2[alsa?]
+ <media-libs/portaudio-20
+ media-libs/soxr
+ x11-libs/wxGTK:3.0[X]
+ alsa? ( media-libs/alsa-lib )
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( >=media-video/ffmpeg-1.2:= )
+ )
+ flac? ( >=media-libs/flac-1.3.1[cxx] )
+ id3tag? ( media-libs/libid3tag )
+ jack? ( virtual/jack )
+ lame? ( >=media-sound/lame-3.70 )
+ lv2? (
+ media-libs/lilv
+ media-libs/lv2
+ media-libs/suil
+ )
+ mad? ( >=media-libs/libmad-0.14.2b )
+ sbsms? ( media-libs/libsbsms )
+ soundtouch? ( >=media-libs/libsoundtouch-1.3.1 )
+ twolame? ( media-sound/twolame )
+ vamp? ( >=media-libs/vamp-plugin-sdk-2.0 )
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.2-fix_building_against_system_portaudio.patch
+ "${FILESDIR}"/${PN}-2.3.2-Fix-building-without-midi.patch
+)
+
+src_prepare() {
+ default
+
+ use midi || sed -i \
+ -e 's:^\(#define EXPERIMENTAL_MIDI_OUT\):// \1:' \
+ src/Experimental.h || die
+}
+
+src_configure() {
+ local WX_GTK_VER="3.0"
+ setup-wxwidgets
+ append-cxxflags -std=gnu++14
+
+ # * always use system libraries if possible
+ # * options listed in the order that configure --help lists them
+ local myeconfargs=(
+ --disable-dynamic-loading
+ --enable-nyquist=local
+ --enable-unicode
+ --with-expat
+ --with-lib-preference=system
+ --with-libsndfile
+ --with-libsoxr
+ --with-mod-script-pipe
+ --with-mod-nyq-bench
+ --with-portaudio
+ --with-widgetextra=local
+ --with-wx-version=${WX_GTK_VER}
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable ladspa)
+ $(use_enable nls)
+ $(use_enable vst)
+ $(use_with ffmpeg)
+ $(use_with flac libflac)
+ $(use_with id3tag libid3tag)
+ $(use_with lame)
+ $(use_with lv2)
+ $(use_with mad libmad)
+ $(use_with midi portmidi local)
+ $(use_with midi "" local)
+ $(use_with portmixer)
+ $(use_with sbsms)
+ $(use_with soundtouch)
+ $(use_with twolame libtwolame)
+ $(use_with vamp libvamp)
+ $(use_with vorbis libvorbis)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Remove bad doc install
+ rm -r "${ED}"/usr/share/doc || die
+
+ # Install our docs
+ einstalldocs
+
+ if use doc ; then
+ docinto html
+ dodoc -r "${WORKDIR}"/help/manual/{m,man,manual}
+ dodoc "${WORKDIR}"/help/manual/{favicon.ico,index.html,quick_help.html}
+ dosym ../../doc/${PF}/html /usr/share/${PN}/help/manual
+ fi
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}