summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew White <mehw.is.me@inventati.org>2023-08-01 17:05:54 +0000
committerSam James <sam@gentoo.org>2023-09-25 01:24:31 +0100
commitf528815c332f51e266338f65336e9d85d134105b (patch)
tree71e0ba8c326d4195d8ec944876a6d59c80901d96 /media-sound/audacity/files/audacity-3.3.3-local-threadpool-libraries.patch
parentsys-devel/crosstool-ng: add 1.26.0, drop 1.26.0_rc2-r1 (diff)
downloadgentoo-f528815c332f51e266338f65336e9d85d134105b.tar.gz
gentoo-f528815c332f51e266338f65336e9d85d134105b.tar.bz2
gentoo-f528815c332f51e266338f65336e9d85d134105b.zip
media-sound/audacity-3.3.3: version bump and new 9999 ebuild
NOTE: Upstream planned the removal of libmad support with the merge of the https://github.com/audacity/audacity/pull/4384 PR. Closes: https://bugs.gentoo.org/906959 Closes: https://bugs.gentoo.org/910398 Package-Manager: portage-3.0.49-r1 Signed-off-by: Matteo Bianco <mehw.is.me@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/32129 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/audacity/files/audacity-3.3.3-local-threadpool-libraries.patch')
-rw-r--r--media-sound/audacity/files/audacity-3.3.3-local-threadpool-libraries.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/audacity/files/audacity-3.3.3-local-threadpool-libraries.patch b/media-sound/audacity/files/audacity-3.3.3-local-threadpool-libraries.patch
new file mode 100644
index 000000000000..a3ef6cf3859d
--- /dev/null
+++ b/media-sound/audacity/files/audacity-3.3.3-local-threadpool-libraries.patch
@@ -0,0 +1,30 @@
+This is an adapted version of:
+
+From 7b5f56ec441fb472b61bae14e1efa353db4d7aca Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@aarsen.me>
+Date: Sun, 18 Dec 2022 13:37:35 +0100
+Subject: [PATCH] Allow using local dependency for threadpool
+
+diff -Nuar a/cmake-proxies/cmake-modules/DependenciesList.cmake b/cmake-proxies/cmake-modules/DependenciesList.cmake
+--- a/cmake-proxies/cmake-modules/DependenciesList.cmake 2023-07-14 03:40:22.518292749 +0200
++++ b/cmake-proxies/cmake-modules/DependenciesList.cmake 2023-07-14 03:40:43.790398232 +0200
+@@ -56,7 +56,6 @@
+ audacity_find_package(PortAudio REQUIRED)
+
+ if( ${_OPT}has_networking )
+- audacity_find_package(ThreadPool REQUIRED)
+ audacity_find_package(CURL REQUIRED CONAN_PACKAGE_NAME libcurl)
+ endif()
+
+diff -Nuar a/libraries/lib-network-manager/CMakeLists.txt b/libraries/lib-network-manager/CMakeLists.txt
+--- a/libraries/lib-network-manager/CMakeLists.txt 2023-07-14 03:38:42.061794613 +0200
++++ b/libraries/lib-network-manager/CMakeLists.txt 2023-07-14 03:38:27.913724456 +0200
+@@ -43,4 +43,8 @@
+
+ set ( DEFINES INTERFACE "HAS_NETWORKING" )
+
++add_library ( threadpool::threadpool INTERFACE IMPORTED GLOBAL )
++target_include_directories ( threadpool::threadpool INTERFACE
++ ${CMAKE_SOURCE_DIR}/lib-src/threadpool
++)
+ audacity_library( ${TARGET} "${SOURCES}" "${LIBRARIES}" "${DEFINES}" "" )