summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-21 12:08:36 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-21 12:08:51 +0100
commit2756b165ad00e4e78bfe5b02a3c0f5bd6f6be82c (patch)
treebcab8e4c1833a175b60c52f4e73de1eccb185bd7 /media-sound/audacity/files
parentmedia-sound/audacity: Fixed compilation with USE="-midi" (diff)
downloadgentoo-2756b165ad00e4e78bfe5b02a3c0f5bd6f6be82c.tar.gz
gentoo-2756b165ad00e4e78bfe5b02a3c0f5bd6f6be82c.tar.bz2
gentoo-2756b165ad00e4e78bfe5b02a3c0f5bd6f6be82c.zip
media-sound/audacity: Fixed compilation with USE="-portmixer"
Closes: https://bugs.gentoo.org/624264 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-sound/audacity/files')
-rw-r--r--media-sound/audacity/files/audacity-2.2.1-portmixer.patch36
-rw-r--r--media-sound/audacity/files/audacity-2.2.2-automake.patch48
2 files changed, 84 insertions, 0 deletions
diff --git a/media-sound/audacity/files/audacity-2.2.1-portmixer.patch b/media-sound/audacity/files/audacity-2.2.1-portmixer.patch
new file mode 100644
index 000000000000..0df43f5c07aa
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.2.1-portmixer.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/624264
+
+Patch by Vladimir
+
+--- audacity-minsrc-2.2.1-rc3/configure.ac
++++ audacity-minsrc-2.2.1-rc3/configure.ac
+@@ -540,7 +540,7 @@
+ [compile with PortMixer [default=yes]])],
+ use_portmixer=$withval,
+ use_portmixer="yes")
+-
++AM_CONDITIONAL([USE_PORTMIXER], [test "$use_portmixer" = yes])
+
+ AC_CANONICAL_HOST
+
+--- audacity-minsrc-2.2.1-rc3/lib-src/Makefile.am
++++ audacity-minsrc-2.2.1-rc3/lib-src/Makefile.am
+@@ -92,7 +92,6 @@
+ libsoxr \
+ lib-widget-extra \
+ lv2 \
+- portmixer \
+ portsmf \
+ sbsms \
+ $(NULL)
+@@ -156,8 +155,10 @@
+ SUBDIRS += portaudio-v19
+ endif
+
++if USE_PORTMIXER
+ # Note: portmixer needs to be linked against (the local or system) portaudio.
+ SUBDIRS += portmixer
++endif
+
+ if USE_LOCAL_PORTSMF
+ SUBDIRS += portsmf
diff --git a/media-sound/audacity/files/audacity-2.2.2-automake.patch b/media-sound/audacity/files/audacity-2.2.2-automake.patch
new file mode 100644
index 000000000000..56343e3ede21
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.2.2-automake.patch
@@ -0,0 +1,48 @@
+Remove subdirs that are non-exisitng in the tarball
+or else autoreconf breaks.
+
+--- audacity-minsrc-2.2.2-rc1/lib-src/Makefile.am
++++ audacity-minsrc-2.2.2-rc1/lib-src/Makefile.am
+@@ -107,18 +107,6 @@
+ SUBDIRS = FileDialog
+ OPTIONAL_SUBDIRS =
+
+-if USE_LOCAL_EXPAT
+-OPTIONAL_SUBDIRS += expat
+-endif
+-
+-if USE_LOCAL_LIBID3TAG
+-OPTIONAL_SUBDIRS += libid3tag
+-endif
+-
+-if USE_LOCAL_LIBMAD
+-OPTIONAL_SUBDIRS += libmad
+-endif
+-
+ if USE_LOCAL_LIBNYQUIST
+ SUBDIRS += libnyquist
+ endif
+@@ -131,23 +119,10 @@
+ OPTIONAL_SUBDIRS += libsoxr
+ endif
+
+-if USE_LOCAL_LIBSOUNDTOUCH
+-OPTIONAL_SUBDIRS += soundtouch
+-endif
+-
+ if USE_LOCAL_LIBTWOLAME
+ OPTIONAL_SUBDIRS += twolame
+ endif
+
+-if USE_LOCAL_LIBVORBIS
+-OPTIONAL_SUBDIRS += libogg libvorbis
+-endif
+-
+-if USE_LOCAL_LIBFLAC
+-# Note: libflac needs to be linked against (the local or system) libogg.
+-OPTIONAL_SUBDIRS += libflac
+-endif
+-
+ if USE_LOCAL_LV2
+ SUBDIRS += lv2
+ endif