summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-04 19:49:58 -0500
committerSam James <sam@gentoo.org>2024-03-05 04:47:49 +0000
commit54238035c9abd9b278e2fd14312e893922c3be5f (patch)
treed955d532e5d3ccd8afd41ab7973a5119e6dca2f8 /media-sound/audacity
parentmedia-gfx/pngtools: mark as LTO-unsafe (diff)
downloadgentoo-54238035c9abd9b278e2fd14312e893922c3be5f.tar.gz
gentoo-54238035c9abd9b278e2fd14312e893922c3be5f.tar.bz2
gentoo-54238035c9abd9b278e2fd14312e893922c3be5f.zip
media-sound/audacity: mark as LTO-unsafe, strict-aliasing unsafe
Bug report says ODR violations, but I could not reproduce since I hit strict-aliasing issues first. I'm assuming both are an issue, but on the other hand either one is a good reason to turn off LTO. Closes: https://bugs.gentoo.org/915226 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/audacity-3.3.3.ebuild9
-rw-r--r--media-sound/audacity/audacity-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/media-sound/audacity/audacity-3.3.3.ebuild b/media-sound/audacity/audacity-3.3.3.ebuild
index a839024bcc60..2cba5da71a87 100644
--- a/media-sound/audacity/audacity-3.3.3.ebuild
+++ b/media-sound/audacity/audacity-3.3.3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
WX_GTK_VER="3.2-gtk3"
-inherit cmake wxwidgets xdg virtualx
+inherit cmake flag-o-matic wxwidgets xdg virtualx
DESCRIPTION="Free crossplatform audio editor"
HOMEPAGE="https://www.audacityteam.org/"
@@ -157,6 +157,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # Reportedly also -Werror=odr but I could not get that far.
+ # https://bugs.gentoo.org/915226
+ # https://github.com/audacity/audacity/issues/6096
+ append-flags -fno-strict-aliasing
+ filter-lto
+
setup-wxwidgets
# * always use system libraries if possible
diff --git a/media-sound/audacity/audacity-9999.ebuild b/media-sound/audacity/audacity-9999.ebuild
index f00f0a9e1f66..be537c7c96c0 100644
--- a/media-sound/audacity/audacity-9999.ebuild
+++ b/media-sound/audacity/audacity-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
WX_GTK_VER="3.2-gtk3"
-inherit cmake wxwidgets xdg virtualx
+inherit cmake flag-o-matic wxwidgets xdg virtualx
DESCRIPTION="Free crossplatform audio editor"
HOMEPAGE="https://www.audacityteam.org/"
@@ -144,6 +144,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # Reportedly also -Werror=odr but I could not get that far.
+ # https://bugs.gentoo.org/915226
+ # https://github.com/audacity/audacity/issues/6096
+ append-flags -fno-strict-aliasing
+ filter-lto
+
setup-wxwidgets
# * always use system libraries if possible