summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-27 19:42:56 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-27 19:44:55 +0100
commitcfb62d0d06d25269c935b7029a1ca656ceecf86f (patch)
treed9dfe9f9181a18d8e0bac379bd63734f9e8952e6 /media-sound/bpmdetect/bpmdetect-0.6.1-r1.ebuild
parentdev-ruby/ruby-webkit2-gtk: initial import for bug 573094 (diff)
downloadgentoo-cfb62d0d06d25269c935b7029a1ca656ceecf86f.tar.gz
gentoo-cfb62d0d06d25269c935b7029a1ca656ceecf86f.tar.bz2
gentoo-cfb62d0d06d25269c935b7029a1ca656ceecf86f.zip
media-sound/bpmdetect: Add patch to respect user flags
Gentoo-Bug: 334465 * EAPI=6 * Added patch by Gavin Pryke to respect all user flags * Fixed QA issues caused by non-compliant .desktop file * Fixed QA issues caused by wrong printf() handling Package-Manager: portage-2.2.27
Diffstat (limited to 'media-sound/bpmdetect/bpmdetect-0.6.1-r1.ebuild')
-rw-r--r--media-sound/bpmdetect/bpmdetect-0.6.1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/bpmdetect/bpmdetect-0.6.1-r1.ebuild b/media-sound/bpmdetect/bpmdetect-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..351532aa0938
--- /dev/null
+++ b/media-sound/bpmdetect/bpmdetect-0.6.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Automatic BPM detection utility"
+HOMEPAGE="http://sourceforge.net/projects/bpmdetect"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/taglib
+ media-libs/id3lib
+ >=media-libs/fmod-4.25.07-r1:1
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ dev-util/scons
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+PATCHES=(
+ "${FILESDIR}/${P}-gcc44_and_fmodex_path.patch"
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+ "${FILESDIR}/${P}-fix-printf-format.patch"
+)
+
+src_prepare() {
+ default
+ tc-export CC CXX
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ export QTDIR="/usr/$(get_libdir)"
+ scons prefix=/usr || die "scons failed"
+}
+
+src_install() {
+ dobin build/${PN}
+ doicon src/${PN}-icon.png
+ domenu src/${PN}.desktop
+ dodoc authors readme todo
+}