summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/cantata/cantata-1.5.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/cantata/cantata-1.5.1.ebuild')
-rw-r--r--media-sound/cantata/cantata-1.5.1.ebuild121
1 files changed, 121 insertions, 0 deletions
diff --git a/media-sound/cantata/cantata-1.5.1.ebuild b/media-sound/cantata/cantata-1.5.1.ebuild
new file mode 100644
index 000000000000..7112c054c944
--- /dev/null
+++ b/media-sound/cantata/cantata-1.5.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_REQUIRED="optional"
+PLOCALES="cs de en_GB es hu ko pl ru zh_CN"
+inherit kde4-base l10n
+
+DESCRIPTION="Featureful and configurable Qt client for the music player daemon (MPD)"
+HOMEPAGE="https://code.google.com/p/cantata/"
+SRC_URI="https://drive.google.com/uc?export=download&id=0Bzghs6gQWi60UktwaTRMTjRIUW8 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="cddb cdda dynamic http-server kde lame mtp musicbrainz online-services qt5 replaygain streams taglib udisks"
+REQUIRED_USE="
+ cddb? ( cdda taglib )
+ cdda? ( udisks || ( cddb musicbrainz ) )
+ lame? ( cdda taglib )
+ mtp? ( taglib udisks )
+ musicbrainz? ( cdda taglib )
+ online-services? ( taglib )
+ qt5? ( !kde )
+ replaygain? ( taglib )
+"
+
+RDEPEND="
+ sys-libs/zlib
+ x11-libs/libX11
+ kde-apps/oxygen-icons
+ cdda? ( media-sound/cdparanoia )
+ cddb? ( media-libs/libcddb )
+ kde? ( $(add_kdeapps_dep kwalletd) )
+ lame? ( media-sound/lame )
+ mtp? ( media-libs/libmtp )
+ musicbrainz? ( media-libs/musicbrainz:5 )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ !qt5? (
+ dev-libs/qjson
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ )
+ replaygain? (
+ media-sound/mpg123
+ virtual/ffmpeg
+ )
+ taglib? (
+ media-libs/taglib[asf,mp4]
+ media-libs/taglib-extras
+ !kde? ( udisks? ( sys-fs/udisks:2 ) )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="${RDEPEND}
+ dynamic? (
+ dev-lang/perl[ithreads]
+ dev-perl/URI
+ )
+"
+
+# cantata has no tests
+RESTRICT="test"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ rm -rf 3rdparty/qtsingleapplication/ || die
+ # qjson ebuild does not support Qt5 yet
+ use qt5 || { rm -rf 3rdparty/qjson/ || die ;}
+ use kde && { rm -rf 3rdparty/solid-lite/ || die ;}
+
+ l10n_find_plocales_changes 'po' '' '.po'
+}
+
+src_configure() {
+ local langs="$(l10n_get_locales)"
+
+ local mycmakeargs=(
+ -DCANTATA_TRANSLATIONS="${langs// /;}"
+ $(cmake-utils_use_enable cdda CDPARANOIA)
+ $(cmake-utils_use_enable cddb)
+ $(cmake-utils_use_enable dynamic)
+ $(cmake-utils_use_enable http-server HTTP_SERVER)
+ $(cmake-utils_use_enable kde)
+ $(cmake-utils_use_enable kde kwallet)
+ $(cmake-utils_use_enable lame)
+ $(cmake-utils_use_enable mtp)
+ $(cmake-utils_use_enable musicbrainz)
+ $(cmake-utils_use_enable online-services ONLINE_SERVICES)
+ $(cmake-utils_use_enable streams)
+ $(cmake-utils_use_enable qt5)
+ $(cmake-utils_use_enable replaygain FFMPEG)
+ $(cmake-utils_use_enable replaygain MPG123)
+ $(cmake-utils_use_enable taglib)
+ $(cmake-utils_use_enable taglib TAGLIB_EXTRAS)
+ $(cmake-utils_use_enable udisks DEVICES_SUPPORT)
+ -DENABLE_HTTP_STREAM_PLAYBACK=OFF
+ -DENABLE_REMOTE_DEVICES=OFF
+ -DENABLE_UDISKS2=ON
+ -DUSE_SYSTEM_MENU_ICON=OFF
+ )
+
+ kde4-base_src_configure
+}