summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-16 13:39:36 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-16 13:39:36 +0200
commit8a16182a8d9136d34c716e5e3093dd2526389394 (patch)
tree17ea1a0b7529d6b06d863a4fdd37b49e141df17e /media-sound/cdplay/cdplay-1.0.ebuild
parentmedia-sound/bplay: Port to EAPI 7 (diff)
downloadgentoo-8a16182a8d9136d34c716e5e3093dd2526389394.tar.gz
gentoo-8a16182a8d9136d34c716e5e3093dd2526389394.tar.bz2
gentoo-8a16182a8d9136d34c716e5e3093dd2526389394.zip
media-sound/cdplay: Port to EAPI 7
Bug: https://bugs.gentoo.org/697274 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/cdplay/cdplay-1.0.ebuild')
-rw-r--r--media-sound/cdplay/cdplay-1.0.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/media-sound/cdplay/cdplay-1.0.ebuild b/media-sound/cdplay/cdplay-1.0.ebuild
index f0763d2b9c7c..2f69fdc3dd03 100644
--- a/media-sound/cdplay/cdplay-1.0.ebuild
+++ b/media-sound/cdplay/cdplay-1.0.ebuild
@@ -1,27 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit toolchain-funcs
-DESCRIPTION="a commandline CD Player"
+DESCRIPTION="A commandline CD Player"
HOMEPAGE="http://www.ta-sa.org/?entry=cdplay"
SRC_URI="http://www.ta-sa.org/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
-IUSE=""
DEPEND="!media-sound/cdtool"
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- || die "emake failed."
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
dobin cdplay
- dodoc Changes CREDITS README TODO
+ einstalldocs
+ dodoc Changes
}