summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-04-17 06:31:51 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-04-17 06:32:57 +0200
commit829f315b73c749c00f47d6b67886bf2935523cd7 (patch)
tree303cee6af15b0093239871502aadd8ed961cd4f9 /media-sound/clementine/files
parentdev-libs/crypto++: add pkgconfig file for clementine (diff)
downloadgentoo-829f315b73c749c00f47d6b67886bf2935523cd7.tar.gz
gentoo-829f315b73c749c00f47d6b67886bf2935523cd7.tar.bz2
gentoo-829f315b73c749c00f47d6b67886bf2935523cd7.zip
media-sound/clementine: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-sound/clementine/files')
-rw-r--r--media-sound/clementine/files/clementine-1.3_rc1-cmake.patch41
-rw-r--r--media-sound/clementine/files/clementine-1.3_rc1-fix-tokenizer.patch21
2 files changed, 0 insertions, 62 deletions
diff --git a/media-sound/clementine/files/clementine-1.3_rc1-cmake.patch b/media-sound/clementine/files/clementine-1.3_rc1-cmake.patch
deleted file mode 100644
index 8aefe97c124c..000000000000
--- a/media-sound/clementine/files/clementine-1.3_rc1-cmake.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- Clementine-1.3rc1/CMakeLists.txt
-+++ Clementine-1.3rc1/CMakeLists.txt
-@@ -60,7 +60,7 @@
-
- pkg_check_modules(CDIO libcdio)
- pkg_check_modules(CHROMAPRINT REQUIRED libchromaprint)
--pkg_search_module(CRYPTOPP cryptopp libcrypto++)
-+#pkg_search_module(CRYPTOPP cryptopp libcrypto++)
- pkg_check_modules(GIO gio-2.0)
- pkg_check_modules(GLIB REQUIRED glib-2.0)
- pkg_check_modules(GOBJECT REQUIRED gobject-2.0)
-@@ -71,7 +71,7 @@
- pkg_check_modules(GSTREAMER_TAG REQUIRED gstreamer-tag-1.0)
- pkg_check_modules(LIBGPOD libgpod-1.0>=0.7.92)
- pkg_check_modules(LIBMTP libmtp>=1.0)
--pkg_check_modules(LIBMYGPO_QT libmygpo-qt>=1.0.9)
-+pkg_check_modules(LIBMYGPO_QT libmygpo-qt>=1.0.8)
- pkg_check_modules(LIBPULSE libpulse)
- pkg_check_modules(LIBXML libxml-2.0)
- pkg_check_modules(QJSON REQUIRED QJson)
-@@ -275,13 +275,14 @@
-
- optional_component(VISUALISATIONS ON "Visualisations")
-
--if(NOT HAVE_SPOTIFY_BLOB AND NOT CRYPTOPP_FOUND)
-- message(FATAL_ERROR "Either crypto++ must be available or the non-GPL Spotify "
-- "code must be compiled in")
--elseif(CRYPTOPP_FOUND)
-+#if(NOT HAVE_SPOTIFY_BLOB AND NOT CRYPTOPP_FOUND)
-+# message(FATAL_ERROR "Either crypto++ must be available or the non-GPL Spotify "
-+# "code must be compiled in")
-+#elseif(CRYPTOPP_FOUND)
- set(HAVE_CRYPTOPP ON)
-- set(HAVE_SPOTIFY_DOWNLOADER ON)
--endif()
-+ set(HAVE_SPOTIFY_DOWNLOADER OFF)
-+ set(HAVE_SPOTIFY_BLOB OFF)
-+#endif()
-
- # Find DBus if it's enabled
- if (HAVE_DBUS)
diff --git a/media-sound/clementine/files/clementine-1.3_rc1-fix-tokenizer.patch b/media-sound/clementine/files/clementine-1.3_rc1-fix-tokenizer.patch
deleted file mode 100644
index 6413bf77de3f..000000000000
--- a/media-sound/clementine/files/clementine-1.3_rc1-fix-tokenizer.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://github.com/clementine-player/Clementine/issues/5297
-
---- src/core/database.cpp
-+++ src/core/database.cpp
-@@ -265,6 +265,16 @@
- StaticInit();
-
- {
-+#ifdef SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER
-+ QVariant v = db.driver()->handle();
-+ if (v.isValid() && qstrcmp(v.typeName(), "sqlite3*") == 0) {
-+ sqlite3* handle = *static_cast<sqlite3**>(v.data());
-+ if (handle) {
-+ sqlite3_db_config(handle, SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER, 1, NULL);
-+ }
-+ }
-+#endif
-+
- QSqlQuery set_fts_tokenizer("SELECT fts3_tokenizer(:name, :pointer)", db);
- set_fts_tokenizer.bindValue(":name", "unicode");
- set_fts_tokenizer.bindValue(