summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-02 17:21:39 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-02 17:38:22 +0100
commit3ab914187dc61039c2b6a78e6c8ce3829648ff6e (patch)
tree68f13d60acfa5bf9793f1351623ed81348332e4e /media-sound/cmix/cmix-1.6.ebuild
parentsys-libs/glibc: Update NPTL_KERN_VER to 3.2 (minimum required by glibc-2.26) (diff)
downloadgentoo-3ab914187dc61039c2b6a78e6c8ce3829648ff6e.tar.gz
gentoo-3ab914187dc61039c2b6a78e6c8ce3829648ff6e.tar.bz2
gentoo-3ab914187dc61039c2b6a78e6c8ce3829648ff6e.zip
media-sound/cmix: Port to EAPI 6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-sound/cmix/cmix-1.6.ebuild')
-rw-r--r--media-sound/cmix/cmix-1.6.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/media-sound/cmix/cmix-1.6.ebuild b/media-sound/cmix/cmix-1.6.ebuild
index 933e6189f5a0..1dc7e4ab02a2 100644
--- a/media-sound/cmix/cmix-1.6.ebuild
+++ b/media-sound/cmix/cmix-1.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils toolchain-funcs
+EAPI=6
-IUSE=""
+inherit toolchain-funcs
DESCRIPTION="command line audio mixer"
HOMEPAGE="http://cmix.sourceforge.net/"
@@ -14,18 +14,13 @@ SLOT="0"
#-amd64: 1.6: 'cmix list' gives: MIXER_READ(SOUND_MIXER_OUTSRC): Input/output error
KEYWORDS="-amd64 ~ppc sparc x86"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-ldflags.patch"
-}
+PATCHES=( "${FILESDIR}/${P}-ldflags.patch" )
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+src_configure() {
+ tc-export CC
}
src_install() {
- einstall || die
dobin cmix
- dodoc README || die
+ einstalldocs
}