summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-08-04 06:49:43 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-08-04 06:49:43 +0200
commit458418a25199839ad014f62700c41008cadac579 (patch)
tree9ad745b659f353a28e1aa06bb69a975291271883 /media-sound/cmusfm
parentmedia-libs/portaudio: removed obsolete 19.06.00-r3 (diff)
downloadgentoo-458418a25199839ad014f62700c41008cadac579.tar.gz
gentoo-458418a25199839ad014f62700c41008cadac579.tar.bz2
gentoo-458418a25199839ad014f62700c41008cadac579.zip
media-sound/cmusfm: bump to 0.4.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/cmusfm')
-rw-r--r--media-sound/cmusfm/Manifest1
-rw-r--r--media-sound/cmusfm/cmusfm-0.4.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/cmusfm/Manifest b/media-sound/cmusfm/Manifest
index aa4b36bd0a30..25addb888217 100644
--- a/media-sound/cmusfm/Manifest
+++ b/media-sound/cmusfm/Manifest
@@ -1 +1,2 @@
DIST cmusfm-0.4.0.tar.gz 41451 BLAKE2B 02fe95079b902c23b594d25c93e99da4ff9a62437a3edb0ff0812db6d490a6320da5e6b5387aa49a55490b02c17b7982d48b3d773687ccffa5d85adee6b54aeb SHA512 dba2ca51953186ca21bd5074367da21c74a371b1ae7578cc851badf3f225274bfe7f3e5f5d7a322c50be9d839af2568339d10fae2d402548e5246a11f6acf9ae
+DIST cmusfm-0.4.1.tar.gz 41960 BLAKE2B 4de96b821c56f64c485dae8ff1e4d342e8f1548650a455ec707f01f53afeb7ca3e333ca62b514e2389a884d9138eb5d228a7376c5a1d5cdd163abc8ab9482608 SHA512 994599675822de5f809b3eedc423c37afe24e88df29fe4474d1834bf1e9573464d2bdbb084181db1d6c3bc0541891ccbb4514afa066c034e39035192ebc95211
diff --git a/media-sound/cmusfm/cmusfm-0.4.1.ebuild b/media-sound/cmusfm/cmusfm-0.4.1.ebuild
new file mode 100644
index 000000000000..b2cac96f9c33
--- /dev/null
+++ b/media-sound/cmusfm/cmusfm-0.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Last.fm scrobbler for cmus music player"
+HOMEPAGE="https://github.com/Arkq/cmusfm"
+SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0=
+ libnotify? ( x11-libs/libnotify )
+"
+RDEPEND="
+ ${DEPEND}
+ media-sound/cmus
+"
+BDEPEND="virtual/pkgconfig"
+
+DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable libnotify)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}