summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-07-01 11:37:57 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-07-01 11:38:11 +0200
commit00926829aaa9dbaef29f922a7a64ac9fbb87632a (patch)
tree07da547efa3fb2e0b156327ee1c1019b9c3d2989 /media-sound/csound
parentmedia-sound/csound: dropped obsolete 6.16.1 (diff)
downloadgentoo-00926829aaa9dbaef29f922a7a64ac9fbb87632a.tar.gz
gentoo-00926829aaa9dbaef29f922a7a64ac9fbb87632a.tar.bz2
gentoo-00926829aaa9dbaef29f922a7a64ac9fbb87632a.zip
media-sound/csound: bump to 6.17.0, eapi8, added python 3.10 & 3.11, updated live
Bug: https://bugs.gentoo.org/855431 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/csound')
-rw-r--r--media-sound/csound/Manifest3
-rw-r--r--media-sound/csound/csound-6.17.0.ebuild216
-rw-r--r--media-sound/csound/csound-9999.ebuild5
3 files changed, 222 insertions, 2 deletions
diff --git a/media-sound/csound/Manifest b/media-sound/csound/Manifest
index ecc8f5175a93..8b3eb36dbfbb 100644
--- a/media-sound/csound/Manifest
+++ b/media-sound/csound/Manifest
@@ -1,3 +1,6 @@
DIST Csound6.16.0_manual_html.zip 24765630 BLAKE2B 3bf6e2202a42dfa826d39ef41282e1942f26cc3f6a3358e0de3a006f102b686342b4e1824a1c3a48ac37ffed31d9353e6946d948751dcc059819da649d63d9cb SHA512 e550a832e365ab186533045d110259699039d08a85ec2f53d4fe36aa31004725b1dc6732f71d9895fa19b3df5f4ec720af1b4f80856a14b0ffbd844c4ab2dbe3
DIST Csound6.16.0_manual_pdf.zip 9640644 BLAKE2B 7bb35f806568a80abbd84a4f4988217bea09f3174881d802f6d61505f044c8a26b59036dcb61ead5315e756a4512eb1fb56b2824f27f09899a8fe1664a386754 SHA512 18347ce7080ca7997e98f8addffcc492c7ec5d8e037e71a33bb46fdbc5b58ec26ee42f370689fc228d4150bd9dedc31c7824ec4c19f3243d512977f4380f9490
+DIST Csound6.17.0_manual_html.zip 25897263 BLAKE2B 3148a60a398d49d6932864d84b2ee37ddf86d5389b91c99443b2c64f7c3b270d040b83ac88b80ebc772c198223682452da1618391fcc8963fe63151b7837037e SHA512 ff2098828e51e78aa80b10736ea162d90c0b1bef3265e469951a5df63250d283e852490cb2a6599dcb1b8a5c185cf4f0b9534f501e4cb755b9da67ecfb1f4ba6
+DIST Csound6.17.0_manual_pdf.zip 9930889 BLAKE2B c0210f2fb97a6707ae6cd0a0cf38cd374f4d4c973b188ee8d418a7efd5c98dc1d4e61867de021ed2859bd8264cc0876b46deb565c358b6efea42f471d39671a9 SHA512 bf664bab1dec073b48853ccf7519086c55ad74af33db86ac7f95746231c18fb10d46a485047788050094e412d27bbd0df65e238d31b01b435989f2fd734189a6
DIST csound-6.16.2-distributable.tar.xz 25169396 BLAKE2B f51c27606f53571d998a62667c55c60a831c076ced993c4eaa8fa24a7e0a8d4872055dc59455b70124f51e2c419018345e2d0e9a33b95d4362f8c6bdecb8310d SHA512 b72c89b2935d92840f5cb7f6d5696e74a3528f5d37858218691f0f6331a69f63b261937a8a8d346d6e182cf8f4a40af85167a4e42fd005cfcf5b4c9daa822f75
+DIST csound-6.17.0-distributable.tar.xz 25231984 BLAKE2B 9767aae3368f33340d80abb84c573e6ceb91bb16448e961f62c679742377e62f611b36341ce7dfb32a2daafc9440c3dff84fe031c9d52b7d86491c383cf79d61 SHA512 b7c5b2f70e82d9dc37074cb217bc146d66293cfea2d69ffd3b0eab9aca302e431eb82b906c8d6494969374988edd6a9c7d04d7676efd085a2dce235988400caa
diff --git a/media-sound/csound/csound-6.17.0.ebuild b/media-sound/csound/csound-6.17.0.ebuild
new file mode 100644
index 000000000000..6e52221543fd
--- /dev/null
+++ b/media-sound/csound/csound-6.17.0.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# As upstream (and we aswell) are not allowed to redistribute scansyn,
+# we have to repackage the tarball. For that purpose use `bash files/repackage.sh version`
+# Reference: https://github.com/csound/csound/issues/1148
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 luajit )
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake lua-single python-single-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/csound/csound.git"
+ inherit git-r3
+else
+ DOC_P="Csound${PV}"
+ SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/${P}-distributable.tar.xz
+ doc? (
+ https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_pdf.zip
+ https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_html.zip
+ )"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Sound design and signal processing system for composition and performance"
+HOMEPAGE="https://csound.github.io/"
+
+LICENSE="LGPL-2.1 doc? ( FDL-1.2+ )"
+SLOT="0"
+IUSE="+alsa beats curl +cxx debug doc double-precision dssi examples jack java lua nls osc portaudio
+portaudio portmidi pulseaudio samples static-libs test +threads +utils vim-syntax"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ alsa? ( threads )
+ java? ( cxx )
+ lua? ( ${LUA_REQUIRED_USE} cxx )
+"
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/yacc
+ doc? ( media-libs/libpng )
+ lua? ( dev-lang/swig )
+ nls? ( sys-devel/gettext )
+ test? (
+ dev-util/cunit
+ ${PYTHON_DEPS}
+ )
+"
+CDEPEND="
+ dev-cpp/eigen:3
+ media-libs/libsndfile
+ media-libs/libsamplerate
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ dssi? (
+ media-libs/dssi
+ media-libs/ladspa-sdk
+ )
+ jack? ( virtual/jack )
+ java? ( >=virtual/jdk-1.8:* )
+ lua? ( ${LUA_DEPS} )
+ osc? ( media-libs/liblo )
+ portaudio? ( media-libs/portaudio )
+ portmidi? ( media-libs/portmidi )
+ pulseaudio? ( media-sound/pulseaudio )
+ utils? ( !media-sound/snd )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ ${CDEPEND}
+ dev-libs/boost
+"
+
+if [[ ${PV} != "9999" ]]; then
+ DEPEND+="doc? ( app-arch/unzip )"
+fi
+
+# requires specific alsa settings
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.13.0-xdg-open.patch"
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
+ -e '/-O3/d' \
+ -i CMakeLists.txt || die
+
+ if use doc; then
+ local png="${WORKDIR}/html/images/delayk.png"
+ pngfix -q --out=${png/.png/fixed.png} ${png} # see pngfix help for exit codes
+ [[ $? -gt 15 ]] && die "Failed to fix ${png}"
+ mv -f ${png/.png/fixed.png} ${png} || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_BELA=OFF
+ -DBUILD_CSBEATS=$(usex beats)
+ -DBUILD_CXX_INTERFACE=$(usex cxx)
+ -DBUILD_DEPRECATED_OPCODES=ON
+ -DBUILD_DSSI_OPCODES=$(usex dssi)
+ -DBUILD_INSTALLER=OFF
+ -DBUILD_JAVA_INTERFACE=$(usex java)
+ -DBUILD_LUA_INTERFACE=$(usex lua)
+ -DBUILD_MULTI_CORE=$(usex threads)
+ -DBUILD_OSC_OPCODES=$(usex osc)
+ -DBUILD_PADSYNTH_OPCODES=ON
+ -DBUILD_RELEASE=ON
+ -DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
+ -DBUILD_STATIC_LIBRARY=$(usex static-libs "ON" $(usex test))
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_UTILITIES=$(usex utils)
+
+ -DFAIL_MISSING=ON
+ -DNEW_PARSER_DEBUG=$(usex debug)
+ -DREQUIRE_PTHREADS=$(usex threads)
+
+ -DUSE_ALSA=$(usex alsa)
+ -DUSE_ATOMIC_BUILTIN=ON
+ -DUSE_COMPILER_OPTIMIZATIONS=ON
+ -DUSE_CURL=$(usex curl)
+ -DUSE_DOUBLE=$(usex double-precision)
+ -DUSE_GETTEXT=$(usex nls)
+ -DUSE_GIT_COMMIT=ON
+ -DUSE_IPMIDI=ON
+ -DUSE_JACK=$(usex jack)
+ -DUSE_LIB64=$([[ $(get_libdir) == "lib64" ]] && echo "ON" || echo "OFF")
+ -DUSE_LRINT=ON
+ -DUSE_PORTAUDIO=$(usex portaudio)
+ -DUSE_PORTMIDI=$(usex portmidi)
+ -DUSE_PULSEAUDIO=$(usex pulseaudio)
+ -DUSE_VCPKG=OFF
+ )
+
+ use java && mycmakeargs+=(
+ -DJAVA_HOME="$(java-config -g JAVA_HOME)"
+ )
+
+ use lua && mycmakeargs+=(
+ -DLUA_H_PATH="$(lua_get_include_dir)"
+ -DLUA_LIBRARY="$(lua_get_shared_lib)"
+ # LUA_MODULE_INSTALL_DIR omitted on purpose, csound Lua module links against liblua
+ # so it must NOT be installed into cmod_dir.
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodoc -r Release_Notes/.
+
+ # generate env.d file
+ cat > "${T}"/62${PN} <<-_EOF_ || die
+ OPCODEDIR$(usex double-precision 64 '')="${EPREFIX}/usr/$(get_libdir)/${PN}/plugins$(usex double-precision 64 '')"
+ CSSTRNGS="${EPREFIX}/usr/share/locale"
+ _EOF_
+ doenvd "${T}"/62${PN}
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ use samples && dodoc -r samples
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins installer/misc/vim/csound_{csd,orc,sco}.vim
+ insinto /usr/share/vim/vimfiles/plugin
+ doins installer/misc/vim/csound.vim
+ fi
+
+ # rename extract to csound_extract (bug #247394)
+ mv "${ED}"/usr/bin/{,csound_}extract || die
+
+ python_optimize
+
+ use java && (dosym lib_jcsound6.so usr/lib64/lib_jcsound.so.1 || die "Failed to create java lib symlink")
+
+ # install docs
+ if [[ ${PV} != "9999" ]] && use doc ; then
+ dodoc "${WORKDIR}"/*.pdf
+ dodoc -r "${WORKDIR}"/html
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog
+ elog "The extract tool is now installed as csound_extract"
+ elog "due to collisions with many other packages (bug #247394)."
+ elog
+ fi
+}
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index 0486ace1f63d..ae7b8aae361e 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# As upstream (and we aswell) are not allowed to redistribute scansyn,
@@ -8,7 +8,7 @@
EAPI=8
LUA_COMPAT=( lua5-1 luajit )
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit cmake lua-single python-single-r1
@@ -44,6 +44,7 @@ BDEPEND="
sys-devel/bison
sys-devel/flex
virtual/yacc
+ doc? ( media-libs/libpng )
lua? ( dev-lang/swig )
nls? ( sys-devel/gettext )
test? (