summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/cvoicecontrol
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/cvoicecontrol')
-rw-r--r--media-sound/cvoicecontrol/Manifest1
-rw-r--r--media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r1.ebuild32
-rw-r--r--media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild42
-rw-r--r--media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo-2.patch35
-rw-r--r--media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo.diff12
-rw-r--r--media-sound/cvoicecontrol/metadata.xml5
6 files changed, 127 insertions, 0 deletions
diff --git a/media-sound/cvoicecontrol/Manifest b/media-sound/cvoicecontrol/Manifest
new file mode 100644
index 000000000000..7bf385aa405a
--- /dev/null
+++ b/media-sound/cvoicecontrol/Manifest
@@ -0,0 +1 @@
+DIST cvoicecontrol-0.9alpha.tar.bz2 78081 RMD160 72f271ba099571e6cd220264aa46853ef511f063 SHA1 bec8bd1ef53d6817aebb13ed42e75a42ca05f388 SHA256 dbcb03ae8370c400b7d398c7715e100b5b719f109e1955a40042cd268df981ad
diff --git a/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r1.ebuild b/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r1.ebuild
new file mode 100644
index 000000000000..53bfa8dfdff4
--- /dev/null
+++ b/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+MY_P=${P/_/}
+
+DESCRIPTION="Console based speech recognition system"
+HOMEPAGE="http://www.kiecza.net/daniel/linux"
+SRC_URI="http://www.kiecza.net/daniel/linux/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo-2.patch
+ sed -i -e "s/install-data-am: install-data-local/install-data-am:/" Makefile.in
+ # Handle documentation with dohtml instead.
+ sed -i -e "s:SUBDIRS = docs:#SUBDIRS = docs:" cvoicecontrol/Makefile.in
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog FAQ README
+ dohtml cvoicecontrol/docs/en/*.html
+}
diff --git a/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild b/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild
new file mode 100644
index 000000000000..cb3d22b054ed
--- /dev/null
+++ b/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE=""
+
+inherit eutils
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Console based speech recognition system"
+HOMEPAGE="http://www.kiecza.net/daniel/linux/"
+SRC_URI="http://www.kiecza.net/daniel/linux/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+KEYWORDS="amd64 ppc sparc x86"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+
+ #remove "docs" from SUBDIRS in Makefile.in
+ #Makefile will try to install few html files directly under the /usr
+ #much easier to do with dohtml
+ cd "${S}"/cvoicecontrol/
+ sed -i -e "s:SUBDIRS = docs:#SUBDIRS = docs:" Makefile.in
+
+ cd "${S}"
+ sed -i -e "s/install-data-am: install-data-local/install-data-am:/" Makefile.in
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ #install documentation
+ dodoc AUTHORS BUGS ChangeLog FAQ README
+ dohtml cvoicecontrol/docs/en/*.html
+}
diff --git a/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo-2.patch b/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo-2.patch
new file mode 100644
index 000000000000..7e1ae985b18d
--- /dev/null
+++ b/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo-2.patch
@@ -0,0 +1,35 @@
+diff -ur cvoicecontrol-0.9alpha.orig/cvoicecontrol/cvoicecontrol.c cvoicecontrol-0.9alpha/cvoicecontrol/cvoicecontrol.c
+--- cvoicecontrol-0.9alpha.orig/cvoicecontrol/cvoicecontrol.c 2002-09-05 19:09:06.000000000 +0300
++++ cvoicecontrol-0.9alpha/cvoicecontrol/cvoicecontrol.c 2007-07-29 23:35:33.000000000 +0300
+@@ -38,6 +38,8 @@
+ #include<sys/select.h>
+ #endif
+
++#include <values.h>
++
+ #include "cvoicecontrol.h"
+
+ #include "model.h"
+diff -ur cvoicecontrol-0.9alpha.orig/cvoicecontrol/microphone_config.c cvoicecontrol-0.9alpha/cvoicecontrol/microphone_config.c
+--- cvoicecontrol-0.9alpha.orig/cvoicecontrol/microphone_config.c 2000-02-19 14:08:47.000000000 +0200
++++ cvoicecontrol-0.9alpha/cvoicecontrol/microphone_config.c 2007-07-29 23:36:08.000000000 +0300
+@@ -1099,8 +1099,6 @@
+ free(command);
+ }
+ fclose(f);
+-
+- free(home);
+ }
+ else /***** couldn't retrieve home directory -> store results in /tmp/ */
+ {
+diff -ur cvoicecontrol-0.9alpha.orig/cvoicecontrol/semaphore.c cvoicecontrol-0.9alpha/cvoicecontrol/semaphore.c
+--- cvoicecontrol-0.9alpha.orig/cvoicecontrol/semaphore.c 2000-02-12 18:05:24.000000000 +0200
++++ cvoicecontrol-0.9alpha/cvoicecontrol/semaphore.c 2007-07-29 23:34:38.000000000 +0300
+@@ -26,6 +26,7 @@
+ ****************************************************************************/
+
+ #include "semaphore.h"
++#include <stdlib.h>
+
+ /********************************************************************************
+ * function must be called prior to semaphore use.
diff --git a/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo.diff b/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo.diff
new file mode 100644
index 000000000000..c22dbb04d47b
--- /dev/null
+++ b/media-sound/cvoicecontrol/files/cvoicecontrol-0.9_alpha-gentoo.diff
@@ -0,0 +1,12 @@
+diff -r -u cvoicecontrol-0.9alpha/cvoicecontrol/cvoicecontrol.c cvoicecontrol-0.9alpha-gentoo/cvoicecontrol/cvoicecontrol.c
+--- cvoicecontrol-0.9alpha/cvoicecontrol/cvoicecontrol.c 2000-02-17 22:59:41.000000000 +0000
++++ cvoicecontrol-0.9alpha-gentoo/cvoicecontrol/cvoicecontrol.c 2002-06-03 23:39:46.000000000 +0000
+@@ -37,6 +37,8 @@
+ #include<sys/select.h>
+ #endif
+
++#include <values.h>
++
+ #include "cvoicecontrol.h"
+
+ #include "model.h"
diff --git a/media-sound/cvoicecontrol/metadata.xml b/media-sound/cvoicecontrol/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/cvoicecontrol/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>