summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-26 06:11:00 +0100
committerSam James <sam@gentoo.org>2021-07-26 06:13:24 +0100
commit63c9db8f6a1e19a68ea402f8b49ce12c063282c5 (patch)
tree8994f6925b197d5974c7a5f5805d10f03a615cbe /media-sound/darkice/darkice-1.4.ebuild
parentmedia-sound/darkice: fix pkg reference in metadata (diff)
downloadgentoo-63c9db8f6a1e19a68ea402f8b49ce12c063282c5.tar.gz
gentoo-63c9db8f6a1e19a68ea402f8b49ce12c063282c5.tar.bz2
gentoo-63c9db8f6a1e19a68ea402f8b49ce12c063282c5.zip
media-sound/darkice: workaround build failure with GCC 11
Closes: https://bugs.gentoo.org/787161 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/darkice/darkice-1.4.ebuild')
-rw-r--r--media-sound/darkice/darkice-1.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-sound/darkice/darkice-1.4.ebuild b/media-sound/darkice/darkice-1.4.ebuild
index b471a55018dc..d5296f02e46e 100644
--- a/media-sound/darkice/darkice-1.4.ebuild
+++ b/media-sound/darkice/darkice-1.4.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit flag-o-matic
+
DESCRIPTION="A live audio streamer"
HOMEPAGE="http://www.darkice.org/"
SRC_URI="https://github.com/rafael2k/${PN}/releases/download/v${PV}/${P}.tar.gz"
@@ -34,6 +36,9 @@ PATCHES=(
)
src_configure() {
+ # bug #787161
+ append-cxxflags -std=c++14
+
local myeconfargs=(
$(use_enable debug)
$(use_with aac faac)