summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-12 17:33:19 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-12 17:43:29 +0100
commit6358c02320d0d333649176de5664154778106267 (patch)
tree381f8087f10d94418465903272ca1310ce3f624d /media-sound/easyeffects/easyeffects-5.0.4.ebuild
parentmedia-sound/pulseeffects: remove 5.0.3 and the live ebuild (diff)
downloadgentoo-6358c02320d0d333649176de5664154778106267.tar.gz
gentoo-6358c02320d0d333649176de5664154778106267.tar.bz2
gentoo-6358c02320d0d333649176de5664154778106267.zip
media-sound/easyeffects: not-quite-new package
At the moment this is essentially the same thing as the latest ebuild in media-sound/pulseeffects, which will eventually be removed. The idea is that although upstream has only been known as easyeffects since 6.0.0, in Gentoo we will use the old name for versions working with PulseAudio (i.e. v4) and the new one for those explicitly requiring PipeWire (i.e. v5 and newer). Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-sound/easyeffects/easyeffects-5.0.4.ebuild')
-rw-r--r--media-sound/easyeffects/easyeffects-5.0.4.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/easyeffects/easyeffects-5.0.4.ebuild b/media-sound/easyeffects/easyeffects-5.0.4.ebuild
new file mode 100644
index 000000000000..e050d932ceae
--- /dev/null
+++ b/media-sound/easyeffects/easyeffects-5.0.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils meson
+
+DESCRIPTION="Limiter, auto volume and many other plugins for PipeWire applications"
+HOMEPAGE="https://github.com/wwmm/easyeffects"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/wwmm/easyeffects"
+else
+ SRC_URI="https://github.com/wwmm/easyeffects/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="bs2b calf rubberband"
+
+#TODO: optional : lilv, zam-plugins (check from archlinux pkg)
+RDEPEND="!media-sound/pulseeffects
+ >=dev-libs/boost-1.41:=
+ >=dev-cpp/glibmm-2.56.0:2
+ >=dev-cpp/gtkmm-3.24:3.0
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libsigc++-2.10:2
+ >=x11-libs/gtk+-3.18:3
+ >=media-libs/lilv-0.24.2-r1
+ >=media-libs/lsp-plugins-1.1.24[lv2]
+ >=media-libs/gstreamer-1.12.0:1.0
+ >=media-libs/gst-plugins-good-1.12.0:1.0
+ >=media-libs/gst-plugins-bad-1.12.0:1.0
+ >=media-plugins/gst-plugins-ladspa-1.12.0:1.0
+ >=media-plugins/gst-plugins-lv2-1.12.0:1.0
+ >=media-libs/zita-convolver-3.0.0
+ media-libs/libebur128
+ >=media-video/pipewire-0.3.24[gstreamer]
+ sys-apps/dbus
+ bs2b? ( >=media-plugins/gst-plugins-bs2b-1.12.0:1.0 )
+ calf? ( >=media-plugins/calf-0.90.0[lv2] )
+ rubberband? ( media-libs/rubberband )"
+# see 47a950b00c6db383ad07502a8fc396ecca98c1ce for dev-libs/appstream-glib
+# and sys-devel/gettext depends reasoning
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ sys-devel/gettext"
+BDEPEND="dev-util/itstool
+ media-libs/libsamplerate
+ virtual/pkgconfig"
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}