summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-01 14:01:04 +0000
committerMarek Szuba <marecki@gentoo.org>2022-01-01 14:10:57 +0000
commit3d14f524eb0d5369e57a0f13127bcd5341732a09 (patch)
treeba7c2da2e8274789b828a0bd7cdeedc52e66901b /media-sound/easyeffects
parentmedia-sound/easyeffects: drop 5.0.4-r1, 6.1.4 (diff)
downloadgentoo-3d14f524eb0d5369e57a0f13127bcd5341732a09.tar.gz
gentoo-3d14f524eb0d5369e57a0f13127bcd5341732a09.tar.bz2
gentoo-3d14f524eb0d5369e57a0f13127bcd5341732a09.zip
media-sound/easyeffects: update "no C++20 support" error message
gcc versions older than 10 require -std value "c++2a" rather than "c++20". Since tests and research conducted by the user who reported this problem show that easyeffects-6 cannot be built using gcc-9 owing to the fact the <ranges> library has only been available in gcc since 10.1 (fortunately we do not have to handle the 10.0 case here because the oldest gcc-10 version currently in the tree is 10.3.0), along with the age of gcc-9, we shan't even bother even bother patching meson.build to support the old value. Closes: https://bugs.gentoo.org/830256 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-sound/easyeffects')
-rw-r--r--media-sound/easyeffects/easyeffects-6.1.5.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-sound/easyeffects/easyeffects-6.1.5.ebuild b/media-sound/easyeffects/easyeffects-6.1.5.ebuild
index e2384d6fb9ab..7a4a2e6d2b7d 100644
--- a/media-sound/easyeffects/easyeffects-6.1.5.ebuild
+++ b/media-sound/easyeffects/easyeffects-6.1.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -61,7 +61,7 @@ BDEPEND="dev-libs/appstream-glib
pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]] ; then
if ! test-flag-CXX -std=c++20 ; then
- die "You need at least GCC 8 or Clang 10 for C++20-specific compiler flags"
+ die "${PN} requires degree of C++20 support only available since GCC 10 or Clang 10"
fi
fi
}