summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-05-25 09:51:24 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-05-25 09:51:24 +0200
commit23d4e22242b32eefd85a6c3287f2b27136f62a67 (patch)
tree554d2d8505200a28f85f363cdc73a3ec0515ed95 /media-sound/exaile/exaile-4.1.1.ebuild
parentmedia-sound/abcmidi: bump to 2021.05.21 (diff)
downloadgentoo-23d4e22242b32eefd85a6c3287f2b27136f62a67.tar.gz
gentoo-23d4e22242b32eefd85a6c3287f2b27136f62a67.tar.bz2
gentoo-23d4e22242b32eefd85a6c3287f2b27136f62a67.zip
media-sound/exaile: bump to 4.1.1
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/exaile/exaile-4.1.1.ebuild')
-rw-r--r--media-sound/exaile/exaile-4.1.1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/exaile/exaile-4.1.1.ebuild b/media-sound/exaile/exaile-4.1.1.ebuild
new file mode 100644
index 000000000000..fa7f552d22f3
--- /dev/null
+++ b/media-sound/exaile/exaile-4.1.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-single-r1 xdg
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exaile/exaile.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_/-}/${PN}-${PV/_/}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+DESCRIPTION="GTK+ based media player aiming to be similar to Amarok"
+HOMEPAGE="https://www.exaile.org/"
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+# IUSE+=cddb if have dev-python/cddb-py
+IUSE="libnotify nls scrobbler"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gst-plugins-base-1.6:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+ media-plugins/gst-plugins-meta:1.0
+ >=x11-libs/gtk+-3.10:3[introspection]
+ libnotify? ( >=x11-libs/libnotify-0.7[introspection] )
+ $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygobject-3.13.2:3[${PYTHON_MULTI_USEDEP}]
+ >=media-libs/mutagen-1.10[${PYTHON_MULTI_USEDEP}]
+ scrobbler? ( dev-python/pylast[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+
+RESTRICT="test" #315589
+
+PATCHES=(
+ "${FILESDIR}/${P}-metainfo.patch"
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ use nls && emake locale
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/usr/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ python_optimize "${D}/usr/$(get_libdir)/${PN}"
+ python_optimize "${D}/usr/share/${PN}"
+}