summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-08-10 08:17:59 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-08-10 08:18:23 +0200
commite793c8eeba9ada4be595b43295e2289b348eb66e (patch)
treecb14a294613c1bfceccdfb65c1ea2a4f7609dc6d /media-sound/exaile
parentdev-java/jdbc-postgresql: add 42.4.1 - CVE-2022-31197 (diff)
downloadgentoo-e793c8eeba9ada4be595b43295e2289b348eb66e.tar.gz
gentoo-e793c8eeba9ada4be595b43295e2289b348eb66e.tar.bz2
gentoo-e793c8eeba9ada4be595b43295e2289b348eb66e.zip
media-sound/exaile: bump to 4.1.2
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/Manifest1
-rw-r--r--media-sound/exaile/exaile-4.1.2.ebuild68
-rw-r--r--media-sound/exaile/exaile-9999.ebuild4
3 files changed, 69 insertions, 4 deletions
diff --git a/media-sound/exaile/Manifest b/media-sound/exaile/Manifest
index 27e78fd8afdf..544d8b19db0c 100644
--- a/media-sound/exaile/Manifest
+++ b/media-sound/exaile/Manifest
@@ -1 +1,2 @@
DIST exaile-4.1.1.tar.gz 3641073 BLAKE2B 34222ddba782dd51897c017d7a77da9a796e45dad69983f934e76cc559c2e52f2173ee418004943ca087fd894439bc42a6eff2a5d6146e6189ec1cd478f5d08b SHA512 babf37253054fbeb6dad33aedafe969201860d4f35222d577343256730be943682c1a5f2f7cec7c574695624cb2b7abbdff4e6eaada848d22fea073c2c44bd23
+DIST exaile-4.1.2.tar.gz 3708188 BLAKE2B 859d77bac62df0843291fdc0de4888079c8f103da3cdf3417d0cd5ba67cf5199a8a1e89d20403efbc6793dfcd7b8333708df74ff535e0912fb02502a13702a0a SHA512 7711f9e062088b02362bbd404f7c61a0f1c128e29e42ce657dc092cac351641f6000846c9da843866bf28ccbd68cf1b07731ba1c9854d52b33c0448e87d0e93b
diff --git a/media-sound/exaile/exaile-4.1.2.ebuild b/media-sound/exaile/exaile-4.1.2.ebuild
new file mode 100644
index 000000000000..5fd5b6a75bca
--- /dev/null
+++ b/media-sound/exaile/exaile-4.1.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1 xdg
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exaile/exaile.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_/-}/${PN}-${PV/_/}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+DESCRIPTION="GTK+ based media player aiming to be similar to Amarok"
+HOMEPAGE="https://www.exaile.org/"
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+# IUSE+=cddb if have dev-python/cddb-py
+IUSE="libnotify nls scrobbler"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+RDEPEND="${PYTHON_DEPS}
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-libs/gtk+:3[introspection]
+ libnotify? ( x11-libs/libnotify[introspection] )
+ $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
+ ')
+"
+
+RESTRICT="test" #315589
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ use nls && emake locale
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/usr/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ python_optimize "${D}/usr/$(get_libdir)/${PN}"
+ python_optimize "${D}/usr/share/${PN}"
+}
diff --git a/media-sound/exaile/exaile-9999.ebuild b/media-sound/exaile/exaile-9999.ebuild
index 36c7f3272d08..5fd5b6a75bca 100644
--- a/media-sound/exaile/exaile-9999.ebuild
+++ b/media-sound/exaile/exaile-9999.ebuild
@@ -48,10 +48,6 @@ RDEPEND="${PYTHON_DEPS}
RESTRICT="test" #315589
-PATCHES=(
- "${FILESDIR}/${PN}-4.1.1-metainfo.patch"
-)
-
pkg_setup() {
python-single-r1_pkg_setup
}