summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-09-06 23:50:46 +0200
committerSebastian Pipping <sping@gentoo.org>2020-09-06 23:50:46 +0200
commit656cd41374098f2ebecba24298782c3d6f3e92b9 (patch)
tree1d8ef691d8f074a2fcc91eff55fe9ff03d014670 /media-sound/fapg/fapg-0.43.ebuild
parentdev-haskell/neat-interpolation: remove old (diff)
downloadgentoo-656cd41374098f2ebecba24298782c3d6f3e92b9.tar.gz
gentoo-656cd41374098f2ebecba24298782c3d6f3e92b9.tar.bz2
gentoo-656cd41374098f2ebecba24298782c3d6f3e92b9.zip
media-sound/fapg: 0.43
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'media-sound/fapg/fapg-0.43.ebuild')
-rw-r--r--media-sound/fapg/fapg-0.43.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/fapg/fapg-0.43.ebuild b/media-sound/fapg/fapg-0.43.ebuild
new file mode 100644
index 000000000000..e50690223847
--- /dev/null
+++ b/media-sound/fapg/fapg-0.43.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fast Audio Playlist Generator"
+HOMEPAGE="http://royale.zerezo.com/fapg/"
+SRC_URI="http://royale.zerezo.com/fapg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="xspf"
+
+DEPEND="xspf? ( >=dev-libs/uriparser-0.6.3 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf=""
+ use xspf || myconf="${myconf} --disable-xspf"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}