summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-02-24 11:00:55 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-02-24 11:00:55 +0100
commit643ef6a0f0d67f7ac1b7f29bc81cb4c78d9dac34 (patch)
tree8c149674066d0444d8ed1dd167a1c54423e920dd /media-sound/fluidsynth
parentdev-java/ant-apache-log4j: Switch to log4j-12-api:2 (diff)
downloadgentoo-643ef6a0f0d67f7ac1b7f29bc81cb4c78d9dac34.tar.gz
gentoo-643ef6a0f0d67f7ac1b7f29bc81cb4c78d9dac34.tar.bz2
gentoo-643ef6a0f0d67f7ac1b7f29bc81cb4c78d9dac34.zip
media-sound/fluidsynth: fixed direct cc call in 2.2.5
Closes: https://bugs.gentoo.org/733940 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.2.5.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/fluidsynth-2.2.5.ebuild b/media-sound/fluidsynth/fluidsynth-2.2.5.ebuild
index 90271801e90c..51908c546139 100644
--- a/media-sound/fluidsynth/fluidsynth-2.2.5.ebuild
+++ b/media-sound/fluidsynth/fluidsynth-2.2.5.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CMAKE_ECLASS=cmake
-inherit cmake-multilib systemd
+inherit cmake-multilib systemd toolchain-funcs
DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
HOMEPAGE="https://www.fluidsynth.org"
@@ -42,6 +42,7 @@ DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
src_configure() {
local mycmakeargs=(
+ -DCMAKE_C_COMPILER="$(tc-getCC)"
-Denable-alsa=$(usex alsa)
-Denable-aufile=ON
-Denable-dbus=$(usex dbus)