summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-18 21:36:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-20 15:03:25 +0200
commitced31d5f1a315a9281b2c811ea9dd7cdeca4b3b2 (patch)
treee1af12681405290f1ad358181fed8ce2f626b4e0 /media-sound/fluidsynth
parentprofiles/prefix/make.defaults: PYTHON TARGET are incremental vars (diff)
downloadgentoo-ced31d5f1a315a9281b2c811ea9dd7cdeca4b3b2.tar.gz
gentoo-ced31d5f1a315a9281b2c811ea9dd7cdeca4b3b2.tar.bz2
gentoo-ced31d5f1a315a9281b2c811ea9dd7cdeca4b3b2.zip
media-sound/fluidsynth: 1.1.11 version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest1
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.11.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 1c6265ecf9e3..e71f30c37a49 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,2 +1,3 @@
+DIST fluidsynth-1.1.11.tar.gz 634566 BLAKE2B ed135533c9e3e807794e0eca8117d430aa299b8772b2b6c85f6233e7e497d69f43381d9c7cf2de5ce8638f5dc616339bd28cecc3cdc23408bf5883a0b14fee79 SHA512 ad7c634426b29e5a05d67addf32d43a9ccb11a1fe3cfc09ad617416b9df3dc99a48191377f5027232521380737dde2d9b59833516d1bffb90f410bab3bbe140c
DIST fluidsynth-1.1.6.tar.gz 958735 BLAKE2B 9be1e72238545d78f2aded9e98336639ba83d2272b3247ac86609e84331fb8517eb29b505d269719196468bdbf645496c9f4f4426ac232b16f19b3b8b1c3450f SHA512 2dcb8a8a1634273cc93c45b6e21b87ac45a023c768cffdadda0a4e611eab8d5bbea0e1ba59e5f147488054cfa6fcaf561399ae275a665c76082b8738a80778bb
DIST fluidsynth-1.1.9.tar.gz 630651 BLAKE2B 2e6faa1126778a98b1960146046490331f943dfe78dcbf66aeaac16deda3ea0bca2eca747e7041ba752d136360b2003ae89b0d936df78a6cd9d5024bd3cd834e SHA512 9bbe9143dc55a0e10e33efd62698e28b598a7ede95d44f193a93c5e29920c7b6d08f7f5ba96bd2c1c42a4b184134d4e811f643fdc0077be714c0cf72635de235
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.11.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.11.ebuild
new file mode 100644
index 000000000000..8cabd6cdfd40
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.11.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="https://github.com/FluidSynth/fluidsynth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ alsa? (
+ >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}]
+ lash? ( >=media-sound/lash-0.5.4-r2[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ >=media-libs/ladspa-cmt-1.16-r3[${MULTILIB_USEDEP}]
+ >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( >=media-libs/portaudio-19_pre20111121-r1[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ readline? ( >=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}] )
+ sndfile? ( >=media-libs/libsndfile-1.0.25[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+DOCS=( AUTHORS NEWS README.md THANKS TODO doc/{fluidsynth-v11-devdoc,xtrafluid}.txt )
+
+src_configure() {
+ # autotools based build system has AC_CHECK_LIB(pthread, pthread_create) wrt
+ # bug #436762
+ append-flags -pthread
+
+ local mycmakeargs=(
+ -Denable-alsa=$(usex alsa)
+ -Denable-dbus=$(usex dbus)
+ -Denable-debug=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladcca=OFF
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-readline=$(usex readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/*.c
+ fi
+}