summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-05-07 09:27:19 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-05-07 09:27:19 +0200
commit6bc7fd3ff8c46d84b6025c00403a20c4052f9b32 (patch)
tree5c75a46a620277141b2503778966ce7a99dd2bbf /media-sound/frescobaldi
parentmedia-sound/aeolus: bump to 0.10.1 (diff)
downloadgentoo-6bc7fd3ff8c46d84b6025c00403a20c4052f9b32.tar.gz
gentoo-6bc7fd3ff8c46d84b6025c00403a20c4052f9b32.tar.bz2
gentoo-6bc7fd3ff8c46d84b6025c00403a20c4052f9b32.zip
media-sound/frescobaldi: bump to 3.2
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/frescobaldi')
-rw-r--r--media-sound/frescobaldi/Manifest1
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/Manifest b/media-sound/frescobaldi/Manifest
index 1f87cd3dde60..f94e88e995ed 100644
--- a/media-sound/frescobaldi/Manifest
+++ b/media-sound/frescobaldi/Manifest
@@ -1 +1,2 @@
DIST frescobaldi-3.1.3.tar.gz 6691789 BLAKE2B 88a08240997aad11d9bf31c57a844a42e341e7641649f5cfb52571beb63fa4c29382136eae7758e5fff1cc6a4f8eb2942ca9b09b8217d7243c699041c951081d SHA512 595c4628df1923dffa44987ba858827a50d5415e9a01b45c87def2a6625d22c8b9b2e988c49dec20bba750cfc1ff4512e6f67875c3a2b23e440ef7231856c159
+DIST frescobaldi-3.2.tar.gz 6696111 BLAKE2B e74a8c3a59c6dc5187538785bc5971dd996cf897c6428ff510775bad58aa4c04dd69b91f3821b9c868a3e7f13b6cae6f76814188de2620542959039e768c9be0 SHA512 403ae6cfe145595fef0ffe06ce4fd595a0417201b19e5f2315944b45cdcec50592296424f2bf2c7e3eccbe3dbeb9ff5bfc4aa7813241d8168bc057e7bf5539b3
diff --git a/media-sound/frescobaldi/frescobaldi-3.2.ebuild b/media-sound/frescobaldi/frescobaldi-3.2.ebuild
new file mode 100644
index 000000000000..1b7def16a0ee
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 xdg
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="https://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/python-ly[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ media-sound/lilypond"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+}