summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-09 15:39:27 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-09 15:44:43 -0700
commit78de16124a8079ca35362f9428bb8f86997b6848 (patch)
treef8751f454faf583b3b7d78f86964d54b6f15b87c /media-sound/gnome-music
parentgnome-base/gnome-desktop: Version bump to 40.2 (diff)
downloadgentoo-78de16124a8079ca35362f9428bb8f86997b6848.tar.gz
gentoo-78de16124a8079ca35362f9428bb8f86997b6848.tar.bz2
gentoo-78de16124a8079ca35362f9428bb8f86997b6848.zip
media-sound/gnome-music: Version bump to 40.1.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-sound/gnome-music')
-rw-r--r--media-sound/gnome-music/Manifest1
-rw-r--r--media-sound/gnome-music/gnome-music-40.1.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index cdb63278bc32..1e13ebf460f0 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1 +1,2 @@
DIST gnome-music-40.0.tar.xz 977412 BLAKE2B acb1823fce3bb7fc8a319a22125deb2c36f4c5cb18f3ea3d21462c1fc71fb52deeb21ffb52ecd5f57aecc975e21dbcec82122f3d4c6fa10f088280efe314a4b7 SHA512 7b1cecd4afe22439e1ee4975c9f6a98690d7abc3a02914483284c258c9bc265d5b3c75cbc9e216603aaeacdc4fdeeff250f2c4e8eff01b84cfe313004266d93f
+DIST gnome-music-40.1.1.tar.xz 978092 BLAKE2B cf9e41e1d519431c33edbd03eb72565612d127d7f6fd82ca34d46b1b3ed58073b7435d3b5b80b149a5fc47ea549018756914dbef5e512cb036303b64b4882083 SHA512 3095dfd31dc32f831e776055d5c1f8c32af5958be632050f709f5c3991b272769edac09a339638de2accf6aae4bf6e8dd1f377a0136897eade2c21d2ebce5f5e
diff --git a/media-sound/gnome-music/gnome-music-40.1.1.ebuild b/media-sound/gnome-music/gnome-music-40.1.1.ebuild
new file mode 100644
index 000000000000..e4f1fbfad036
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-40.1.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Music"
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.50:2
+ >=net-libs/gnome-online-accounts-3.35.90[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=x11-libs/gtk+-3.24.7:3[introspection]
+ >=dev-libs/libdazzle-3.28.0[introspection]
+ >=media-libs/libmediaart-1.9.1:2.0[introspection]
+ net-libs/libsoup:2.4[introspection]
+ app-misc/tracker:3=[introspection(+)]
+ >=x11-libs/pango-1.44:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.36.1:3[cairo,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pycairo-1.14.0[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=media-libs/grilo-0.3.13:0.3[introspection]
+ >=media-plugins/grilo-plugins-0.3.13:0.3
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${DEPEND}
+ || (
+ app-misc/tracker-miners:3[gstreamer]
+ app-misc/tracker-miners:3[ffmpeg]
+ )
+ x11-libs/libnotify[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.3[tracker]
+ x11-misc/xdg-user-dirs
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ sed -e '/sys.path.insert/d' -i "${S}"/gnome-music.in || die "python fixup sed failed"
+ xdg_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gnome-music
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}