summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gpodder/gpodder-3.8.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gpodder/gpodder-3.8.3.ebuild')
-rw-r--r--media-sound/gpodder/gpodder-3.8.3.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/gpodder/gpodder-3.8.3.ebuild b/media-sound/gpodder/gpodder-3.8.3.ebuild
new file mode 100644
index 000000000000..3fddce5618f7
--- /dev/null
+++ b/media-sound/gpodder/gpodder-3.8.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+# Required for python_fix_shebang:
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A free cross-platform podcast aggregator"
+HOMEPAGE="http://gpodder.org/"
+SRC_URI="http://gpodder.org/src/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+dbus bluetooth gstreamer ipod kernel_linux mtp test webkit"
+
+#TODO: add QML UI deps (USE=qt4) and make pygtk optional, see README
+COMMON_DEPEND=">=dev-python/eyeD3-0.7
+ >=dev-python/feedparser-5.1.2
+ >=dev-python/mygpoclient-1.7
+ >=dev-python/pygtk-2.16:2
+ dbus? ( dev-python/dbus-python )
+ bluetooth? ( net-wireless/bluez )
+ gstreamer? ( dev-python/gst-python:0.10 )
+ ipod? ( media-libs/libgpod[python] )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ webkit? ( dev-python/pywebkitgtk )"
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/iproute2 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-apps/help2man
+ test? (
+ dev-python/minimock
+ dev-python/coverage
+ )"
+
+src_prepare() {
+ sed -i -e '/setup.py.*install/d' makefile || die
+ # Fix for "AttributeError: 'gPodder' object has no attribute 'toolbar'":
+ python_fix_shebang .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ distutils-r1_src_install
+}
+
+src_test() {
+ emake releasetest
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}