summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gsm/gsm-1.0.13-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gsm/gsm-1.0.13-r1.ebuild')
-rw-r--r--media-sound/gsm/gsm-1.0.13-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/gsm/gsm-1.0.13-r1.ebuild b/media-sound/gsm/gsm-1.0.13-r1.ebuild
new file mode 100644
index 000000000000..6dc0b84883ad
--- /dev/null
+++ b/media-sound/gsm/gsm-1.0.13-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib multilib-minimal toolchain-funcs versionator
+
+DESCRIPTION="Lossy speech compression library and tool"
+HOMEPAGE="http://packages.qa.debian.org/libg/libgsm.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="gsm"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-"$(replace_version_separator 2 '-pl' )"
+
+DOCS=( ChangeLog MACHINES MANIFEST README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-shared.patch \
+ "${FILESDIR}"/${PN}-1.0.12-memcpy.patch \
+ "${FILESDIR}"/${PN}-1.0.12-64bit.patch
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ # From upstream Makefile. Define this if your host multiplies
+ # floats faster than integers, e.g. on a SPARCstation.
+ use sparc && append-flags -DUSE_FLOAT_MUL -DFAST
+
+ emake -j1 CCFLAGS="${CFLAGS} -c -DNeedFunctionPrototypes=1" \
+ LD="$(tc-getCC)" AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ dodir /usr/bin /usr/$(get_libdir) /usr/include/gsm /usr/share/man/man{1,3}
+
+ emake -j1 INSTALL_ROOT="${D}"/usr \
+ LD="$(tc-getCC)" AR="$(tc-getAR)" CC="$(tc-getCC)" \
+ GSM_INSTALL_LIB="${D}"/usr/$(get_libdir) \
+ GSM_INSTALL_INC="${D}"/usr/include/gsm \
+ GSM_INSTALL_MAN="${D}"/usr/share/man/man3 \
+ TOAST_INSTALL_MAN="${D}"/usr/share/man/man1 \
+ install
+
+ dolib lib/libgsm.so*
+
+ dosym ../gsm/gsm.h /usr/include/libgsm/gsm.h
+}