summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-27 19:21:35 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-27 19:31:06 +0100
commitb5811548d148ae50b0410743290dadbe018d1985 (patch)
treea0225a6a7e0d482d5fdb5f55f9115b03c6e65334 /media-sound/guitarix/guitarix-9999.ebuild
parentdev-python/python-nbxmpp: Add myself as maintainer and add upstream (diff)
downloadgentoo-b5811548d148ae50b0410743290dadbe018d1985.tar.gz
gentoo-b5811548d148ae50b0410743290dadbe018d1985.tar.bz2
gentoo-b5811548d148ae50b0410743290dadbe018d1985.zip
media-sound/guitarix: added live ebuild
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/guitarix/guitarix-9999.ebuild')
-rw-r--r--media-sound/guitarix/guitarix-9999.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/guitarix/guitarix-9999.ebuild b/media-sound/guitarix/guitarix-9999.ebuild
new file mode 100644
index 000000000000..a459bbec550b
--- /dev/null
+++ b/media-sound/guitarix/guitarix-9999.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils xdg git-r3
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Virtual guitar amplifier for Linux"
+HOMEPAGE="http://guitarix.org/"
+EGIT_REPO_URI="https://git.code.sf.net/p/guitarix/git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="bluetooth debug lv2 nls +standalone zeroconf"
+REQUIRED_USE="|| ( lv2 standalone )"
+
+COMMON_DEPEND="dev-cpp/eigen:3
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
+ >=media-libs/libsndfile-1.0.17
+ >=media-libs/zita-convolver-3:=
+ media-libs/zita-resampler
+ >=net-misc/curl-7.26.0
+ >=sci-libs/fftw-3.1.2:3.0=
+ x11-libs/gtk+:2
+ lv2? ( media-libs/lv2 )
+ standalone? (
+ dev-libs/boost:=
+ media-libs/liblrdf
+ media-libs/lilv
+ virtual/jack
+ bluetooth? ( net-wireless/bluez )
+ zeroconf? ( net-dns/avahi )
+ )
+"
+# clearlooks gtk engine and roboto fonts are required for correct ui rendering
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gtk-engines
+ standalone? (
+ media-fonts/roboto
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )
+"
+
+S="${WORKDIR}/${P}/trunk"
+
+DOCS=( changelog README )
+
+src_configure() {
+ local myconf=(
+ --cxxflags-debug=""
+ --cxxflags-release="-DNDEBUG"
+ --ldflags="${LDFLAGS}"
+ --enable-lfs
+ --lib-dev
+ --no-desktop-update
+ --no-faust
+ --no-ldconfig
+ --shared-lib
+ $(use_enable nls)
+ $(usex bluetooth "" "--no-bluez")
+ $(usex debug "--debug" "")
+ $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui")
+ $(usex standalone "" "--no-standalone")
+ $(usex zeroconf "" "--no-avahi")
+ )
+ waf-utils_src_configure "${myconf[@]}"
+}