summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.124.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.124.1.ebuild')
-rw-r--r--media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.124.1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.124.1.ebuild b/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.124.1.ebuild
new file mode 100644
index 000000000000..7cec76766fe8
--- /dev/null
+++ b/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.124.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils multilib multilib-minimal
+
+DESCRIPTION="A low-latency audio server"
+HOMEPAGE="http://www.jackaudio.org"
+SRC_URI="http://www.jackaudio.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="cpu_flags_x86_3dnow altivec alsa coreaudio doc debug examples oss cpu_flags_x86_sse pam"
+
+# readline: only used for jack_transport -> useless for non native ABIs
+# libsndfile: ditto for jackrec
+RDEPEND="
+ sys-libs/readline
+ >=media-libs/libsndfile-1.0.0
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ >=media-libs/libsamplerate-0.1.8-r1[${MULTILIB_USEDEP}]
+ !media-sound/jack-cvs
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r7
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+RDEPEND="${RDEPEND}
+ alsa? ( sys-process/lsof )
+ pam? ( sys-auth/realtime-base )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-sparc-cpuinfo.patch"
+ epatch "${FILESDIR}/${PN}-freebsd.patch"
+}
+
+DOCS=( AUTHORS TODO README )
+
+multilib_src_configure() {
+ local myconf=""
+
+ # Disabling CPU Detection (dynsimd) disables optimized asm routines (3dnow
+ # or sse)
+ if use cpu_flags_x86_3dnow || use cpu_flags_x86_sse ; then
+ myconf="${myconf} --enable-dynsimd"
+ fi
+
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable altivec) \
+ $(use_enable alsa) \
+ $(use_enable coreaudio) \
+ $(use_enable debug) \
+ $(use_enable oss) \
+ --disable-portaudio \
+ $(use_enable cpu_flags_x86_sse sse) \
+ --with-html-dir=/usr/share/doc/${PF} \
+ --disable-dependency-tracking \
+ --libdir=/usr/$(get_libdir) \
+ ${myconf}
+
+ if [ "${ABI}" != "${DEFAULT_ABI}" ] ; then
+ for i in tools man ; do
+ sed -i -e "s/ ${i}//" Makefile || die
+ done
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}/example-clients"
+ docompress -x /usr/share/doc/${PF}/example-clients
+ fi
+}