summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-06 23:35:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-06 23:35:46 +0200
commite36bef29e29af5924a23142d958e600c33b322fd (patch)
treedf0db023a1e8550dba990df5ed46f4f6b341b523 /media-sound/kaudiocreator/kaudiocreator-1.3_p20170806.ebuild
parentwww-apps/gitea: Remove old (diff)
downloadgentoo-e36bef29e29af5924a23142d958e600c33b322fd.tar.gz
gentoo-e36bef29e29af5924a23142d958e600c33b322fd.tar.bz2
gentoo-e36bef29e29af5924a23142d958e600c33b322fd.zip
media-sound/kaudiocreator: Add 1.3_p20170806 KF5-based snapshot
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-sound/kaudiocreator/kaudiocreator-1.3_p20170806.ebuild')
-rw-r--r--media-sound/kaudiocreator/kaudiocreator-1.3_p20170806.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/kaudiocreator/kaudiocreator-1.3_p20170806.ebuild b/media-sound/kaudiocreator/kaudiocreator-1.3_p20170806.ebuild
new file mode 100644
index 000000000000..1cce31a26416
--- /dev/null
+++ b/media-sound/kaudiocreator/kaudiocreator-1.3_p20170806.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="CD ripper and audio encoder frontend based on KDE Frameworks"
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=107645"
+SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2 FDL-1.2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_kdeapps_dep libkcddb)
+ $(add_kdeapps_dep libkcompactdisc)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ media-libs/libdiscid
+ media-libs/phonon[qt5]
+ >=media-libs/taglib-1.5
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep audiocd-kio)
+"
+
+DOCS=( Changelog TODO )
+
+pkg_postinst() {
+ local stcnt=0
+
+ has_version media-libs/flac && stcnt=$((stcnt+1))
+ has_version media-sound/lame && stcnt=$((stcnt+1))
+ has_version media-sound/vorbis-tools && stcnt=$((stcnt+1))
+
+ if [[ ${stcnt} -lt 1 ]] ; then
+ elog "You should emerge at least one of the following packages"
+ elog "for ${PN} to do anything useful."
+ fi
+ elog "Optional runtime dependencies:"
+ elog "FLAC - media-libs/flac"
+ elog "MP3 - media-sound/lame"
+ elog "OGG - media-sound/vorbis-tools"
+
+ kde5_pkg_postinst
+}