summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-06-01 02:01:32 +0300
committerMichał Górny <mgorny@gentoo.org>2019-06-01 12:53:58 +0200
commitdb65d65e43626b808d74bc5647c34f39031e771b (patch)
treed5dfcaf6620827b7a6da0db12fba978f75f32f87 /media-sound/klick/klick-0.12.2-r2.ebuild
parentmedia-sound/klick: take maintainership (diff)
downloadgentoo-db65d65e43626b808d74bc5647c34f39031e771b.tar.gz
gentoo-db65d65e43626b808d74bc5647c34f39031e771b.tar.bz2
gentoo-db65d65e43626b808d74bc5647c34f39031e771b.zip
media-sound/klick: EAPI=7 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/klick/klick-0.12.2-r2.ebuild')
-rw-r--r--media-sound/klick/klick-0.12.2-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-sound/klick/klick-0.12.2-r2.ebuild b/media-sound/klick/klick-0.12.2-r2.ebuild
new file mode 100644
index 000000000000..6c88ea4ac1a5
--- /dev/null
+++ b/media-sound/klick/klick-0.12.2-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit python-any-r1 scons-utils toolchain-funcs
+
+DESCRIPTION="An advanced command-line based metronome for JACK"
+HOMEPAGE="http://das.nasophon.de/klick"
+SRC_URI="http://das.nasophon.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug osc rubberband"
+
+RDEPEND="dev-libs/boost
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ virtual/jack
+ osc? ( media-libs/liblo )
+ rubberband? ( media-libs/rubberband )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sconstruct.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+HTML_DOCS=( doc/manual.html )
+
+src_configure() {
+ MYSCONS=(
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ LINKFLAGS="${LDFLAGS}"
+ PREFIX="${EPREFIX}/usr"
+ DESTDIR="${D}"
+ DEBUG=$(usex debug)
+ OSC=$(usex osc)
+ RUBBERBAND=$(usex rubberband)
+ )
+}
+
+src_compile() {
+ escons "${MYSCONS[@]}"
+}
+
+src_install() {
+ escons "${MYSCONS[@]}" install
+ einstalldocs
+}