summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2022-06-15 16:06:19 +0300
committerSam James <sam@gentoo.org>2022-06-16 17:32:01 +0100
commit0a31dc2cfb95fd8ba41654682c77716f9c7fe043 (patch)
tree5491b702f5ab07a5d264270de811999394d03fa2 /media-sound/klick
parentnet-libs/tox: Update the live ebuild (diff)
downloadgentoo-0a31dc2cfb95fd8ba41654682c77716f9c7fe043.tar.gz
gentoo-0a31dc2cfb95fd8ba41654682c77716f9c7fe043.tar.bz2
gentoo-0a31dc2cfb95fd8ba41654682c77716f9c7fe043.zip
media-sound/klick: add Python 3.10 support
Also fix variable scope issue. Closes: https://bugs.gentoo.org/846074 Closes: https://bugs.gentoo.org/836078 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/25909 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/klick')
-rw-r--r--media-sound/klick/klick-0.12.2-r3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/klick/klick-0.12.2-r3.ebuild b/media-sound/klick/klick-0.12.2-r3.ebuild
new file mode 100644
index 000000000000..dc5e78d639f9
--- /dev/null
+++ b/media-sound/klick/klick-0.12.2-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1 scons-utils toolchain-funcs
+
+DESCRIPTION="An advanced command-line based metronome for JACK"
+HOMEPAGE="http://das.nasophon.de/klick"
+SRC_URI="http://das.nasophon.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug osc rubberband"
+
+RDEPEND="media-libs/libsamplerate
+ media-libs/libsndfile
+ virtual/jack
+ osc? ( media-libs/liblo )
+ rubberband? ( media-libs/rubberband )"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sconstruct.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+HTML_DOCS=( doc/manual.html )
+
+src_configure() {
+ MYSCONS=(
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ LINKFLAGS="${LDFLAGS}"
+ PREFIX="${EPREFIX}/usr"
+ DEBUG=$(usex debug)
+ OSC=$(usex osc)
+ RUBBERBAND=$(usex rubberband)
+ )
+}
+
+src_compile() {
+ escons "${MYSCONS[@]}"
+}
+
+src_install() {
+ escons "${MYSCONS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}