summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lash/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lash/files')
-rw-r--r--media-sound/lash/files/lash-0.5.4-gcc47.patch13
-rw-r--r--media-sound/lash/files/lash-0.5.4-glibc2.8.patch14
-rw-r--r--media-sound/lash/files/lash-0.5.4-strcmp.patch12
-rw-r--r--media-sound/lash/files/lash-0.5.4-swig_version_comparison.patch15
-rw-r--r--media-sound/lash/files/lash-0.5.4-underlinking.patch23
5 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/lash/files/lash-0.5.4-gcc47.patch b/media-sound/lash/files/lash-0.5.4-gcc47.patch
new file mode 100644
index 000000000000..c1afeda71e90
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-gcc47.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/451668
+http://pkgs.fedoraproject.org/cgit/lash.git/tree/lash-gcc47.patch
+
+--- liblash/lash.c
++++ liblash/lash.c
+@@ -22,6 +22,7 @@
+ #include <string.h>
+ #include <strings.h>
+ #include <pthread.h>
++#include <sys/resource.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <sys/socket.h>
diff --git a/media-sound/lash/files/lash-0.5.4-glibc2.8.patch b/media-sound/lash/files/lash-0.5.4-glibc2.8.patch
new file mode 100644
index 000000000000..56bc89af0291
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-glibc2.8.patch
@@ -0,0 +1,14 @@
+--- liblash/socket.c.old 2008-06-26 15:20:44.227064193 +0200
++++ liblash/socket.c 2008-06-26 15:21:18.245063129 +0200
+@@ -20,6 +20,11 @@
+
+ #define _POSIX_SOURCE /* addrinfo */
+
++#ifdef LASH_BUILD
++#define _GNU_SOURCE
++#include "config.h"
++#endif /* LASH_BUILD */
++
+ #include <stdint.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
diff --git a/media-sound/lash/files/lash-0.5.4-strcmp.patch b/media-sound/lash/files/lash-0.5.4-strcmp.patch
new file mode 100644
index 000000000000..ea9f7ee2fda3
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-strcmp.patch
@@ -0,0 +1,12 @@
+clients/synth/lash.c:85:2: warning: implicit declaration of function ‘strcmp’ [-Wimplicit-function-declaration]
+
+--- clients/synth/lash.c
++++ clients/synth/lash.c
+@@ -22,6 +22,7 @@
+
+ #include "config.h"
+
++#include <string.h>
+ #include <unistd.h>
+
+ #include <lash/lash.h>
diff --git a/media-sound/lash/files/lash-0.5.4-swig_version_comparison.patch b/media-sound/lash/files/lash-0.5.4-swig_version_comparison.patch
new file mode 100644
index 000000000000..6dcd4366da7c
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-swig_version_comparison.patch
@@ -0,0 +1,15 @@
+--- acinclude.m4
++++ acinclude.m4
+@@ -40,9 +40,9 @@
+ if test -z "$available_patch" ; then
+ [available_patch=0]
+ fi
+- if test $available_major -ne $required_major \
+- -o $available_minor -ne $required_minor \
+- -o $available_patch -lt $required_patch ; then
++ if ! { test $available_major -gt $required_major \
++ || test $available_major -eq $required_major -a $available_minor -ge $required_minor \
++ || test $available_major -eq $required_major -a $available_minor -eq $required_minor -a $available_patch -ge $required_patch; } ; then
+ AC_MSG_WARN([SWIG version >= $1 is required. You have $swig_version. You should look at http://www.swig.org])
+ SWIG='echo "Error: SWIG version >= $1 is required. You have '"$swig_version"'. You should look at http://www.swig.org" ; false'
+ else
diff --git a/media-sound/lash/files/lash-0.5.4-underlinking.patch b/media-sound/lash/files/lash-0.5.4-underlinking.patch
new file mode 100644
index 000000000000..3e52807d267f
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-underlinking.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/367589
+http://bugs.gentoo.org/514748
+
+--- clients/control/Makefile.am
++++ clients/control/Makefile.am
+@@ -18,6 +18,7 @@
+
+ lash_control_LDADD = \
+ $(top_builddir)/liblash/liblash.la \
+- $(LASH_LIBS) @READLINE_LIBS@
++ $(LASH_LIBS) @READLINE_LIBS@ \
++ $(UUID_LIBS)
+
+ endif
+--- clients/synth/Makefile.am
++++ clients/synth/Makefile.am
+@@ -20,4 +20,5 @@
+ $(JACK_LIBS) \
+ $(ALSA_LIBS) \
+ $(GTK2_LIBS) \
+- -lpthread
++ -lpthread \
++ -lm