summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lash/lash-0.5.4-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lash/lash-0.5.4-r1.ebuild')
-rw-r--r--media-sound/lash/lash-0.5.4-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-sound/lash/lash-0.5.4-r1.ebuild b/media-sound/lash/lash-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..9ea2c4a16f3f
--- /dev/null
+++ b/media-sound/lash/lash-0.5.4-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.6"
+inherit autotools eutils python
+
+DESCRIPTION="LASH Audio Session Handler"
+HOMEPAGE="http://www.nongnu.org/lash/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
+IUSE="alsa debug gtk python static-libs" # doc
+
+RDEPEND="dev-libs/libxml2
+ media-sound/jack-audio-connection-kit
+ alsa? ( media-libs/alsa-lib )
+ gtk? ( x11-libs/gtk+:2 )
+ || ( sys-libs/readline dev-libs/libedit )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ python? ( >=dev-lang/swig-1.3.40 )"
+# doc? ( >=app-text/texi2html-5 )
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e '/texi2html/s:-number:&-sections:' \
+ docs/Makefile.am || die #422045
+
+ epatch \
+ "${FILESDIR}"/${P}-glibc2.8.patch \
+ "${FILESDIR}"/${P}-swig_version_comparison.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # 'no' could be '$(usex doc)' but we use the pregenerated lash-manual.html
+ export ac_cv_prog_lash_texi2html=no #422045
+
+ # --enable-pylash would disable it
+ local myconf
+ use python || myconf='--disable-pylash'
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable gtk gtk2) \
+ $(use_enable debug) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dohtml docs/lash-manual-html-*/lash-manual.html
+ prune_libtool_files --all # --all for _lash.la in python directory
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize lash.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup lash.py
+}