summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lmms/lmms-1.1.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lmms/lmms-1.1.3.ebuild')
-rw-r--r--media-sound/lmms/lmms-1.1.3.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/media-sound/lmms/lmms-1.1.3.ebuild b/media-sound/lmms/lmms-1.1.3.ebuild
new file mode 100644
index 000000000000..db9a5060802a
--- /dev/null
+++ b/media-sound/lmms/lmms-1.1.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Free alternative to popular programs such as Fruityloops, Cubase and Logic"
+HOMEPAGE="http://lmms.sourceforge.net/"
+SRC_URI="https://github.com/LMMS/lmms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa debug fluidsynth jack ogg portaudio pulseaudio sdl stk vst"
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4[accessibility]
+ >=media-libs/libsamplerate-0.1.8
+ >=media-libs/libsndfile-1.0.11
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ >=x11-libs/fltk-1.3.0_rc3:1
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.99.0 )
+ ogg? ( media-libs/libvorbis
+ media-libs/libogg )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl
+ >=media-libs/sdl-sound-1.0.1 )
+ stk? ( media-libs/stk )
+ vst? ( app-emulation/wine )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.5"
+RDEPEND="${RDEPEND}
+ media-plugins/swh-plugins
+ media-plugins/caps-plugins
+ media-plugins/tap-plugins
+ media-libs/ladspa-cmt"
+
+DOCS="README AUTHORS TODO"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWANT_SYSTEM_SR=TRUE
+ -DWANT_CAPS=FALSE
+ -DWANT_TAP=FALSE
+ -DWANT_SWH=FALSE
+ -DWANT_CMT=FALSE
+ -DWANT_CALF=TRUE
+ -DCMAKE_INSTALL_LIBDIR=$(get_libdir)
+ $(cmake-utils_use_want alsa ALSA)
+ $(cmake-utils_use_want jack JACK)
+ $(cmake-utils_use_want ogg OGGVORBIS)
+ $(cmake-utils_use_want portaudio PORTAUDIO)
+ $(cmake-utils_use_want pulseaudio PULSEAUDIO)
+ $(cmake-utils_use_want sdl SDL)
+ $(cmake-utils_use_want stk STK)
+ $(cmake-utils_use_want vst VST)
+ $(cmake-utils_use_want fluidsynth SF2)"
+ cmake-utils_src_configure
+}