summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-30 22:39:45 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-30 22:40:04 +0100
commit11c1a64c02b9f7aafea4744a84990ac63cb947d0 (patch)
treed14e63a0adbd4ce10645c530d9c79099745b75a2 /media-sound/lmms
parentmedia-sound/lmms: Bump to version 1.2.0_rc4 (diff)
downloadgentoo-11c1a64c02b9f7aafea4744a84990ac63cb947d0.tar.gz
gentoo-11c1a64c02b9f7aafea4744a84990ac63cb947d0.tar.bz2
gentoo-11c1a64c02b9f7aafea4744a84990ac63cb947d0.zip
media-sound/lmms: Synced live ebuild.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-sound/lmms')
-rw-r--r--media-sound/lmms/lmms-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/media-sound/lmms/lmms-9999.ebuild b/media-sound/lmms/lmms-9999.ebuild
index ee2e01679215..1782844e67f4 100644
--- a/media-sound/lmms/lmms-9999.ebuild
+++ b/media-sound/lmms/lmms-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils xdg-utils
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -11,8 +11,9 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/LMMS/lmms.git"
inherit git-r3
else
- SRC_URI="https://github.com/LMMS/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/LMMS/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${P/_/-}"
fi
LICENSE="GPL-2 LGPL-2"
@@ -85,3 +86,13 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}