summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-26 17:12:43 +0000
committerSam James <sam@gentoo.org>2021-03-26 17:12:43 +0000
commit24165fcf3b3d275950c05db60da87c7d06ca3233 (patch)
tree14a9f6f106426d8a20151d95070aa5f4f11cb210 /media-sound/mac/mac-4.11.4.5.7-r1.ebuild
parentnet-libs/openmq-cclient: fix build with slibtool, fix epatch (diff)
downloadgentoo-24165fcf3b3d275950c05db60da87c7d06ca3233.tar.gz
gentoo-24165fcf3b3d275950c05db60da87c7d06ca3233.tar.bz2
gentoo-24165fcf3b3d275950c05db60da87c7d06ca3233.zip
media-sound/mac: fix build with slibtool
Thanks-to: orbea <orbea@riseup.net> Closes: https://bugs.gentoo.org/778260 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/mac/mac-4.11.4.5.7-r1.ebuild')
-rw-r--r--media-sound/mac/mac-4.11.4.5.7-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/media-sound/mac/mac-4.11.4.5.7-r1.ebuild b/media-sound/mac/mac-4.11.4.5.7-r1.ebuild
index 521c7ab667ee..121c906229be 100644
--- a/media-sound/mac/mac-4.11.4.5.7-r1.ebuild
+++ b/media-sound/mac/mac-4.11.4.5.7-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic
+inherit autotools flag-o-matic
MY_PN=monkeys-audio
MY_PV=$(ver_cut 1-2)-u$(ver_cut 3)-b$(ver_cut 4)-s$(ver_cut 5)
@@ -39,7 +39,11 @@ RESTRICT="mirror"
src_prepare() {
default
- sed -i -e 's:-O3::' configure || die
+ sed -i -e 's:-O3::' configure{,.in} || die
+
+ # bug #778260
+ sed -i 's/tag=ASM/tag=NASM/' src/MACLib/Assembly/Makefile.am || die
+ eautoreconf
}
src_configure() {