summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-08 10:48:35 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-08 10:48:51 +0200
commit0396facd8f27eee98893cfc68de03905d9b95892 (patch)
tree6a3ab9c23d8bdb78163a8faf99e9380287b7b1f5 /media-sound/milkytracker/milkytracker-1.02.00.ebuild
parentdev-util/re2c: bump up to 2.0.2 (diff)
downloadgentoo-0396facd8f27eee98893cfc68de03905d9b95892.tar.gz
gentoo-0396facd8f27eee98893cfc68de03905d9b95892.tar.bz2
gentoo-0396facd8f27eee98893cfc68de03905d9b95892.zip
media-sound/milkytracker: fixes
1) added xdg 2) switched to virtual/jack 3) fixed compilation wrt rtmidi Closes: https://bugs.gentoo.org/736306 Closes: https://bugs.gentoo.org/735916 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/milkytracker/milkytracker-1.02.00.ebuild')
-rw-r--r--media-sound/milkytracker/milkytracker-1.02.00.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/media-sound/milkytracker/milkytracker-1.02.00.ebuild b/media-sound/milkytracker/milkytracker-1.02.00.ebuild
deleted file mode 100644
index d9dc64d7f6ee..000000000000
--- a/media-sound/milkytracker/milkytracker-1.02.00.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake desktop
-
-# This commit is needed so the milkytrace binary is linked properly, bug 711564
-# It is also ~40kb so it is better to fetch it rather than ship it in-tree
-COMMIT="2b145b074581ddf3b4ad78a402cdf5fab500b125"
-
-DESCRIPTION="FastTracker 2 inspired music tracker"
-HOMEPAGE="https://milkytracker.titandemo.org/"
-SRC_URI="https://github.com/milkytracker/MilkyTracker/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/milkytracker/MilkyTracker/commit/${COMMIT}.patch -> ${P}-cmake.patch"
-
-LICENSE="|| ( GPL-3 MPL-1.1 ) AIFFWriter.m BSD GPL-3 GPL-3+ LGPL-2.1+ MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa jack"
-
-RDEPEND="
- dev-libs/zziplib
- media-libs/libsdl2[X]
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${DISTDIR}/${P}-cmake.patch"
- "${FILESDIR}/${P}-CVE-2019-14464.patch"
- "${FILESDIR}/${P}-CVE-2019-1449x.patch"
- "${FILESDIR}/${P}-CVE-2020-15569.patch"
-)
-
-S="${WORKDIR}/MilkyTracker-${PV}"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package alsa ALSA)
- $(cmake_use_find_package jack JACK)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- newicon resources/pictures/carton.png ${PN}.png
- make_desktop_entry ${PN} MilkyTracker ${PN} \
- "AudioVideo;Audio;Sequencer"
-}