summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mimd/mimd-0.30.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mimd/mimd-0.30.1.ebuild')
-rw-r--r--media-sound/mimd/mimd-0.30.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/mimd/mimd-0.30.1.ebuild b/media-sound/mimd/mimd-0.30.1.ebuild
new file mode 100644
index 000000000000..ca7a3efe069b
--- /dev/null
+++ b/media-sound/mimd/mimd-0.30.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Multicast streaming server for MPEG1/2 and MP3 files"
+HOMEPAGE="http://darkwing.uoregon.edu/~tkay/mim.html"
+SRC_URI="http://darkwing.uoregon.edu/~tkay/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+RDEPEND=">=media-plugins/live-2006.12.08
+ dev-libs/xerces-c"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+live-2006.12.08.patch \
+ "${FILESDIR}"/${P}-fortify_sources.patch
+ cp -f Makefile.in Makefile
+}
+
+src_configure() { :; }
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin mimd || die "dobin failed"
+ dodoc doc/mimd.pod
+
+ if [ -x /usr/bin/pod2html ]; then
+ pod2html < doc/mimd.pod > doc/mimd.html
+ dohtml doc/mimd.html
+ fi
+
+ if [ -x /usr/bin/pod2man ]; then
+ pod2man < doc/mimd.pod > doc/mimd.1
+ doman doc/mimd.1
+ fi
+
+ insinto /usr/share/mimd
+ doins etc/mimd.dtd etc/sample.xml
+}
+
+pkg_postinst() {
+ elog "Please read the documentation (mimd.html or man mimd) for "
+ elog "instructions on configuring mimd. The DTD for the configuration "
+ elog "files is in /usr/share/mimd/mimd.dtd, along with a sample "
+ elog "configuration file (/usr/share/mimd/sample.xml)."
+ ewarn "NOTE: You must have ip multicasting enabled in the kernel for this"
+ ewarn "daemon to work properly."
+}