summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-06-09 09:46:56 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-09 09:47:18 +0200
commitf9f614ac83d77f9bc53426891e555959e51b1566 (patch)
tree19cc7d0d30ace4bf28f44eb8939b433f238224f3 /media-sound/mpdas
parentdev-python/python-bugzilla: Enable py3.10 (diff)
downloadgentoo-f9f614ac83d77f9bc53426891e555959e51b1566.tar.gz
gentoo-f9f614ac83d77f9bc53426891e555959e51b1566.tar.bz2
gentoo-f9f614ac83d77f9bc53426891e555959e51b1566.zip
media-sound/mpdas: bump to 0.4.5
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/mpdas')
-rw-r--r--media-sound/mpdas/Manifest1
-rw-r--r--media-sound/mpdas/mpdas-0.4.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/mpdas/Manifest b/media-sound/mpdas/Manifest
index 0899637ecaaa..7e50e0f079bd 100644
--- a/media-sound/mpdas/Manifest
+++ b/media-sound/mpdas/Manifest
@@ -1 +1,2 @@
DIST mpdas-0.4.2.tar.gz 15695 BLAKE2B 907417050ab1b3d6577311e633b060dad2ff834b5436b7ed086ab5cb9ef291004916fc07cbe18ba4b80eeec8573775cc8e212b93d4ed103cbab3ce81082a18ae SHA512 cebd3c027002ac5283834edf3a1338b449c4a78261690cb5d25c57f767f1b0b81ff8ca5c64d79d6aecf5e86ba0c7b63a51131f6cc9031f2922e92eeddcada353
+DIST mpdas-0.4.5.tar.gz 19108 BLAKE2B aa5aec147574cc70572cada56ee495415a06ce5a8c4e19db7288ee1e52cb5d1b6f15a31955e46a526f9db1eff94bf282cb9804379dbd4cf979412ee7f575dde2 SHA512 18737f20b408a38424c46a611a1184e8e9ab78d1c3bddddc37423c8437007b87c343dfe03fd989c9c54dcc532ed1f567ba854d2ba8e12f344399267dc83daaab
diff --git a/media-sound/mpdas/mpdas-0.4.5.ebuild b/media-sound/mpdas/mpdas-0.4.5.ebuild
new file mode 100644
index 000000000000..007f26dddaae
--- /dev/null
+++ b/media-sound/mpdas/mpdas-0.4.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="AudioScrobbler client for MPD written in C++"
+HOMEPAGE="https://50hz.ws/mpdas/"
+SRC_URI="https://50hz.ws/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ media-libs/libmpdclient
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ tc-export CXX
+ emake CONFIG="/etc"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+ dodoc mpdasrc.example README
+}
+
+pkg_postinst() {
+ elog "For further configuration help consult the README in"
+ elog "${EPREFIX}/usr/share/doc/${PF}"
+}