summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/muine/muine-0.8.11-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/muine/muine-0.8.11-r3.ebuild')
-rw-r--r--media-sound/muine/muine-0.8.11-r3.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/media-sound/muine/muine-0.8.11-r3.ebuild b/media-sound/muine/muine-0.8.11-r3.ebuild
new file mode 100644
index 000000000000..f26d8faff348
--- /dev/null
+++ b/media-sound/muine/muine-0.8.11-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+
+inherit gnome2 mono-env eutils multilib
+
+DESCRIPTION="A music player for GNOME"
+HOMEPAGE="http://muine.gooeylinux.org/"
+SRC_URI="mirror://gnome/sources/muine/0.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="flac mad vorbis"
+
+RDEPEND="
+ x11-themes/gnome-icon-theme
+ >=dev-lang/mono-2
+ >=x11-libs/gtk+-2.6:2
+ >=dev-dotnet/gtk-sharp-2.12.9:2
+ >=dev-dotnet/glade-sharp-2.12.6:2
+ >=dev-dotnet/gnome-sharp-2.6:2
+ >=dev-dotnet/gconf-sharp-2.6:2
+ >=dev-dotnet/gnomevfs-sharp-2.6:2
+ >=dev-dotnet/ndesk-dbus-0.4
+ >=dev-dotnet/ndesk-dbus-glib-0.3
+ >=dev-dotnet/taglib-sharp-2.0.3
+ sys-libs/gdbm
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-gconf:0.10
+ media-plugins/gst-plugins-gnomevfs:0.10
+ flac? ( media-plugins/gst-plugins-flac:0.10 )
+ mad? ( media-plugins/gst-plugins-mad:0.10 )
+ vorbis? (
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-vorbis:0.10
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/scrollkeeper
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.29
+"
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS PLUGINS README TODO"
+
+ # Fix multimedia key support for >=Gnome-2.22
+ epatch "${FILESDIR}/${P}-multimedia-keys.patch"
+
+ # Replace some deprecated gtk functions
+ epatch "${FILESDIR}/${P}-drop-deprecated.patch"
+
+ # Update icons, upstream bug #623480
+ sed "s:stock_timer:list-add:g" -i src/AddWindow.cs src/StockIcons.cs || die
+ sed "s:stock_music-library:folder-music:g" -i data/glade/PlaylistWindow.glade \
+ src/Actions.cs src/StockIcons.cs || die
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ insinto /usr/$(get_libdir)/${PN}/plugins
+ doins "${S}"/plugins/TrayIcon.dll
+}