summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/musescore/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/musescore/files')
-rw-r--r--media-sound/musescore/files/musescore-1.1-sline.patch11
-rw-r--r--media-sound/musescore/files/musescore-1.2-cflags.patch64
-rw-r--r--media-sound/musescore/files/musescore-1.3-cflags.patch113
-rw-r--r--media-sound/musescore/files/musescore-1.3-freetype251.patch19
4 files changed, 207 insertions, 0 deletions
diff --git a/media-sound/musescore/files/musescore-1.1-sline.patch b/media-sound/musescore/files/musescore-1.1-sline.patch
new file mode 100644
index 000000000000..15345803b63f
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.1-sline.patch
@@ -0,0 +1,11 @@
+--- mscore-1.1/mscore/mscore/exportxml.cpp.orig
++++ mscore-1.1/mscore/mscore/exportxml.cpp
+@@ -2363,7 +2363,7 @@
+ el->userOff().y());
+ */
+ if (el->type() == HAIRPIN || el->type() == OTTAVA || el->type() == TEXTLINE) {
+- SLine* sl = static_cast<const SLine*>(el);
++ SLine* sl = static_cast<SLine*>(el);
+ // printf("slin segsz=%d", sl->lineSegments().size());
+ if (sl->lineSegments().size() > 0) {
+ LineSegment* seg = sl->lineSegments().at(0);
diff --git a/media-sound/musescore/files/musescore-1.2-cflags.patch b/media-sound/musescore/files/musescore-1.2-cflags.patch
new file mode 100644
index 000000000000..d3450b8cae92
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.2-cflags.patch
@@ -0,0 +1,64 @@
+--- mscore-1.2/mscore/al/CMakeLists.txt
++++ mscore-1.2/mscore/al/CMakeLists.txt
+@@ -42,7 +42,7 @@
+
+ set_source_files_properties(
+ dsp.cpp xml.cpp tempo.cpp sig.cpp pos.cpp fraction.cpp
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ set_source_files_properties(dspSSE.cpp
+--- mscore-1.2/mscore/awl/CMakeLists.txt
++++ mscore-1.2/mscore/awl/CMakeLists.txt
+@@ -61,7 +61,7 @@
+
+ set_target_properties( awl
+ PROPERTIES COMPILE_FLAGS
+- "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(awl mops1)
+--- mscore-1.2/mscore/CMakeLists.txt
++++ mscore-1.2/mscore/CMakeLists.txt
+@@ -253,9 +253,6 @@
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ )
+
+-set(CMAKE_CXX_FLAGS_DEBUG "")
+-set(CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG")
+-
+ if (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ if (MINGW)
+ set(FLAGS -DQT_DEBUG -DQT_DLL)
+@@ -264,9 +261,9 @@
+ endif (MINGW)
+ else (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ if (MINGW)
+- set(FLAGS -O2 -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
++ set(FLAGS -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
+ else (MINGW)
+- set(FLAGS -O2 -DNDEBUG -DQT_NO_DEBUG)
++ set(FLAGS -DNDEBUG -DQT_NO_DEBUG)
+ endif (MINGW)
+ endif (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+
+@@ -276,7 +273,7 @@
+ add_custom_command(
+ OUTPUT ${PROJECT_BINARY_DIR}/all.h.pch
+ COMMAND ${CMAKE_CXX_COMPILER}
+- -x c++-header -g ${FLAGS}
++ -x c++-header ${FLAGS}
+ -I${QT_INCLUDE_DIR}
+ -o all.h.pch all.h
+ DEPENDS ${PROJECT_BINARY_DIR}/all.h
+@@ -287,7 +284,7 @@
+ add_custom_command(
+ OUTPUT ${PROJECT_BINARY_DIR}/all.h.gch
+ COMMAND ${CMAKE_CXX_COMPILER}
+- -x c++-header -g ${FLAGS} -m32
++ -x c++-header ${FLAGS}
+ -I${QT_HEADERS_DIR}
+ -o all.h.gch all.h
+ DEPENDS ${PROJECT_BINARY_DIR}/all.h
diff --git a/media-sound/musescore/files/musescore-1.3-cflags.patch b/media-sound/musescore/files/musescore-1.3-cflags.patch
new file mode 100644
index 000000000000..44af8851be97
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.3-cflags.patch
@@ -0,0 +1,113 @@
+--- mscore-1.3/mscore/al/CMakeLists.txt
++++ mscore-1.3/mscore/al/CMakeLists.txt
+@@ -42,7 +42,7 @@
+
+ set_source_files_properties(
+ dsp.cpp xml.cpp tempo.cpp sig.cpp pos.cpp fraction.cpp
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ set_source_files_properties(dspSSE.cpp
+--- mscore-1.3/mscore/awl/CMakeLists.txt
++++ mscore-1.3/mscore/awl/CMakeLists.txt
+@@ -61,7 +61,7 @@
+
+ set_target_properties( awl
+ PROPERTIES COMPILE_FLAGS
+- "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(awl mops1)
+--- mscore-1.3/mscore/CMakeLists.txt
++++ mscore-1.3/mscore/CMakeLists.txt
+@@ -257,9 +257,6 @@
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ )
+
+-set(CMAKE_CXX_FLAGS_DEBUG "-g")
+-set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG")
+-
+ if (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ if (MINGW)
+ set(FLAGS -DQT_DEBUG -DQT_DLL)
+@@ -272,9 +269,9 @@
+ endif (MINGW)
+ else (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ if (MINGW)
+- set(FLAGS -O2 -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
++ set(FLAGS -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
+ else (MINGW)
+- set(FLAGS -O2 -DNDEBUG -DQT_NO_DEBUG)
++ set(FLAGS -DNDEBUG -DQT_NO_DEBUG)
+ endif (MINGW)
+ endif (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+
+@@ -284,7 +281,7 @@
+ add_custom_command(
+ OUTPUT ${PROJECT_BINARY_DIR}/all.h.gch
+ COMMAND ${CMAKE_CXX_COMPILER}
+- -x c++-header -g ${FLAGS}
++ -x c++-header ${FLAGS}
+ -I${QT_HEADERS_DIR}
+ -o all.h.gch all.h
+ DEPENDS ${PROJECT_BINARY_DIR}/all.h
+--- mscore-1.3/mscore/fluid/CMakeLists.txt
++++ mscore-1.3/mscore/fluid/CMakeLists.txt
+@@ -28,7 +28,7 @@
+ )
+
+ set_target_properties( fluid
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(fluid mops1)
+--- mscore-1.3/mscore/mscore/CMakeLists.txt
++++ mscore-1.3/mscore/mscore/CMakeLists.txt
+@@ -199,7 +199,7 @@
+ if(CMAKE_BUILD_TYPE MATCHES "DEBUG")
+ set_target_properties( mscore
+ PROPERTIES
+- COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch ${QT_DEFINITIONS} -DQT_SVG_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQT_SCRIPT_LIB"
++ COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch ${QT_DEFINITIONS} -DQT_SVG_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQT_SCRIPT_LIB"
+ LINK_FLAGS "${PROJECT_BINARY_DIR}/resfile.o -mwindows -mconsole -L ${CROSSQT}/lib"
+ )
+ else(CMAKE_BUILD_TYPE MATCHES "DEBUG")
+--- mscore-1.3/mscore/ofqf/CMakeLists.txt
++++ mscore-1.3/mscore/ofqf/CMakeLists.txt
+@@ -34,8 +34,8 @@
+ )
+
+ set_target_properties( ofqf
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(ofqf mops1)
+-ADD_DEPENDENCIES(ofqf mops2)
+\ No newline at end of file
++ADD_DEPENDENCIES(ofqf mops2)
+--- mscore-1.3/mscore/osdabzip/CMakeLists.txt
++++ mscore-1.3/mscore/osdabzip/CMakeLists.txt
+@@ -29,7 +29,7 @@
+ )
+
+ set_target_properties( osdabzip
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(osdabzip mops1)
+--- mscore-1.3/mscore/singleapp/src/CMakeLists.txt
++++ mscore-1.3/mscore/singleapp/src/CMakeLists.txt
+@@ -35,7 +35,7 @@
+ )
+
+ set_target_properties( qtsingleapp
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(qtsingleapp mops1)
diff --git a/media-sound/musescore/files/musescore-1.3-freetype251.patch b/media-sound/musescore/files/musescore-1.3-freetype251.patch
new file mode 100644
index 000000000000..0fbad400e8f9
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.3-freetype251.patch
@@ -0,0 +1,19 @@
+Date: Tue, 15 Apr 2014 16:36:51 +0200
+Subject: [PATCH] Fix compilation with >=freetype-2.5.1 while remaining
+ compatible with older freetype versions.
+
+This fixes Gentoo bug #507712 (https://bugs.gentoo.org/507712)
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+
+--- mscore-1.3/mscore/mscore/genft.cpp
++++ mscore-1.3/mscore/mscore/genft.cpp
+@@ -27,7 +27,7 @@
+
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-#include <freetype/tttables.h>
++#include FT_TRUETYPE_TABLES_H
+ #include "al/xml.h"
+
+ QMap<int, int> codemap;