summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-27 00:31:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-27 00:36:52 +0100
commitb2db5e97df2952c4ee9ce8b64c56cd9cdaa4f04f (patch)
tree3857bbf019a06c706d00f12dbd631710c3fa224a /media-sound/opus-tools/opus-tools-0.1.10.ebuild
parentmedia-libs/mutagen: Bump to version 1.36.1 (diff)
downloadgentoo-b2db5e97df2952c4ee9ce8b64c56cd9cdaa4f04f.tar.gz
gentoo-b2db5e97df2952c4ee9ce8b64c56cd9cdaa4f04f.tar.bz2
gentoo-b2db5e97df2952c4ee9ce8b64c56cd9cdaa4f04f.zip
media-sound/opus-tools: Bump to version 0.1.10
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-sound/opus-tools/opus-tools-0.1.10.ebuild')
-rw-r--r--media-sound/opus-tools/opus-tools-0.1.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/opus-tools/opus-tools-0.1.10.ebuild b/media-sound/opus-tools/opus-tools-0.1.10.ebuild
new file mode 100644
index 000000000000..786c606bc7ba
--- /dev/null
+++ b/media-sound/opus-tools/opus-tools-0.1.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Royalty-free, highly versatile audio codec"
+HOMEPAGE="http://opus-codec.org/"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.opus-codec.org/${PN}.git"
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="https://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="flac"
+
+RDEPEND=">=media-libs/libogg-1.3.0
+ >=media-libs/opus-1.0.3
+ flac? ( >=media-libs/flac-1.1.3 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with flac)
+}
+
+src_install() {
+ default
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}