summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-12-28 09:25:58 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-12-28 09:25:58 +0100
commiteef6437a7b61cda1cc9836a7f2bc9559a81dc606 (patch)
tree7b373f8a31a94687adfa3ff2ceb1502deabbad84 /media-sound/paprefs/paprefs-1.2.ebuild
parenteclass/webapps.eclass: added eapi8 support (diff)
downloadgentoo-eef6437a7b61cda1cc9836a7f2bc9559a81dc606.tar.gz
gentoo-eef6437a7b61cda1cc9836a7f2bc9559a81dc606.tar.bz2
gentoo-eef6437a7b61cda1cc9836a7f2bc9559a81dc606.zip
media-sound/paprefs: bump to 1.2
eapi8 + cleanup Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/paprefs/paprefs-1.2.ebuild')
-rw-r--r--media-sound/paprefs/paprefs-1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/paprefs/paprefs-1.2.ebuild b/media-sound/paprefs/paprefs-1.2.ebuild
new file mode 100644
index 000000000000..ee0a35651ddf
--- /dev/null
+++ b/media-sound/paprefs/paprefs-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic meson xdg
+
+DESCRIPTION="PulseAudio Preferences, configuration dialog for PulseAudio"
+HOMEPAGE="https://freedesktop.org/software/pulseaudio/paprefs"
+SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-cpp/atkmm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ media-sound/pulseaudio[glib]
+ x11-libs/gtk+:3
+ || (
+ x11-themes/tango-icon-theme
+ x11-themes/adwaita-icon-theme
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cxxflags -std=c++11 #568590
+ local mymesonargs=(
+ -Dlynx=false
+ )
+ meson_src_configure
+}