summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-10-01 19:53:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-04 21:11:51 +0200
commitc8cf58ece9bfb785238f7e1d49dc3e2de6712985 (patch)
tree5446fba3d2841eb2d2deb290092f5ccb45ebe392 /media-sound/pasystray/pasystray-0.7.0.ebuild
parentmedia-sound/csound: Drop old (diff)
downloadgentoo-c8cf58ece9bfb785238f7e1d49dc3e2de6712985.tar.gz
gentoo-c8cf58ece9bfb785238f7e1d49dc3e2de6712985.tar.bz2
gentoo-c8cf58ece9bfb785238f7e1d49dc3e2de6712985.zip
media-sound/pasystray: version bump to 0.7.0
This update includes: more configurability for notifications bug fixes, segfault memory leak fixed Signed-off-by: Paul Healy <lmiphay@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10037 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/pasystray/pasystray-0.7.0.ebuild')
-rw-r--r--media-sound/pasystray/pasystray-0.7.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/pasystray/pasystray-0.7.0.ebuild b/media-sound/pasystray/pasystray-0.7.0.ebuild
new file mode 100644
index 000000000000..6da7af40f6ac
--- /dev/null
+++ b/media-sound/pasystray/pasystray-0.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils autotools vcs-snapshot xdg
+
+DESCRIPTION="PulseAudio system tray"
+HOMEPAGE="https://github.com/christophgysin/pasystray"
+SRC_URI="https://github.com/christophgysin/${PN}/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libnotify zeroconf"
+
+RDEPEND="
+ >=dev-libs/glib-2.48.2
+ >=media-sound/pulseaudio-5.0-r3[glib,zeroconf?]
+ zeroconf? ( >=net-dns/avahi-0.6 )
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notify) \
+ $(use_enable zeroconf avahi)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}