summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 20:12:36 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:06:39 +0300
commitf15f272a54419a4d22f7f01bfa7c4a362a2e118a (patch)
treeca00b06ab8792543e981e5c42ba44bf0a74e22c0 /media-sound/pavucontrol-qt/pavucontrol-qt-0.17.0.ebuild
parentx11-terms/qterminal: add version 0.17.0 (diff)
downloadgentoo-f15f272a54419a4d22f7f01bfa7c4a362a2e118a.tar.gz
gentoo-f15f272a54419a4d22f7f01bfa7c4a362a2e118a.tar.bz2
gentoo-f15f272a54419a4d22f7f01bfa7c4a362a2e118a.zip
media-sound/pavucontrol-qt: add version 0.17.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound/pavucontrol-qt/pavucontrol-qt-0.17.0.ebuild')
-rw-r--r--media-sound/pavucontrol-qt/pavucontrol-qt-0.17.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/pavucontrol-qt/pavucontrol-qt-0.17.0.ebuild b/media-sound/pavucontrol-qt/pavucontrol-qt-0.17.0.ebuild
new file mode 100644
index 000000000000..44c2b5627977
--- /dev/null
+++ b/media-sound/pavucontrol-qt/pavucontrol-qt-0.17.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt GUI Pulseaudio Mixer"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ media-sound/pulseaudio[glib]
+"
+RDEPEND="${DEPEND}"