summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-11-09 22:47:20 +0200
committerJimi Huotari <chiitoo@gentoo.org>2022-11-10 14:55:37 +0200
commit65d75d11f2446d145bc0d761e4533fd42fc03375 (patch)
treeff5fc04a89170f90a2e8fe48655a14555eecf3b2 /media-sound/pavucontrol-qt
parentmedia-gfx/lximage-qt: add 1.2.0 (diff)
downloadgentoo-65d75d11f2446d145bc0d761e4533fd42fc03375.tar.gz
gentoo-65d75d11f2446d145bc0d761e4533fd42fc03375.tar.bz2
gentoo-65d75d11f2446d145bc0d761e4533fd42fc03375.zip
media-sound/pavucontrol-qt: add version 1.2.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-sound/pavucontrol-qt')
-rw-r--r--media-sound/pavucontrol-qt/Manifest1
-rw-r--r--media-sound/pavucontrol-qt/pavucontrol-qt-1.2.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/pavucontrol-qt/Manifest b/media-sound/pavucontrol-qt/Manifest
index ce730b024542..a8f933543787 100644
--- a/media-sound/pavucontrol-qt/Manifest
+++ b/media-sound/pavucontrol-qt/Manifest
@@ -1,2 +1,3 @@
DIST pavucontrol-qt-0.17.0.tar.xz 104120 BLAKE2B 13cfd361d134a8fb79eb6bf20ab2e2755b998e4c46105efb0e7d29a171262d795b6f77629c4b066b0d786cf1bd60784d0d7155c4b77d23ff2a0a148f3f7764a5 SHA512 b6c77fc78c62051c8c0484edb09d1e2a347fc30ae8b65f1e4b3d279499abd47aeaf19c2cb3037871ef8885a5bc787f3d0307d7c0aa0699deaba3129501fb9a3a
DIST pavucontrol-qt-1.0.0.tar.xz 110092 BLAKE2B 82d95fb649422d5d9921b8d1b7759367689d884e7bf134c47a7254f2bdf9c0eaf31fc4f96cbc105112b52c5619f31f13a1816545b7d619f4b358fc185c4d1652 SHA512 10e03572287a468b2c8062098edab1e5783a6b02ec3629ff0d65f87a8dbe2e490752d9edfdba1f0886165302ec9da615467344ae6b7fa97afde63491e193df89
+DIST pavucontrol-qt-1.2.0.tar.xz 113024 BLAKE2B 3a18ea2a9c8d60d9042b43b4ebca92d6102ce1d5076168bb7dc23613f24d604d20e239bdefd15133988708b6be9b9070b480c2cfdf79a2467b65c17dd9aa8f25 SHA512 c13a04e87aa9aec8ac8261259c0eda1d7f31df5f1e6f5c8ca782a56bc3e1d6f1d9236875c68adfd620fa0b1d3430f1a470d83158c8d82ccd8155ba71d7e8ab6e
diff --git a/media-sound/pavucontrol-qt/pavucontrol-qt-1.2.0.ebuild b/media-sound/pavucontrol-qt/pavucontrol-qt-1.2.0.ebuild
new file mode 100644
index 000000000000..fcdb32fd8529
--- /dev/null
+++ b/media-sound/pavucontrol-qt/pavucontrol-qt-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt GUI Pulseaudio Mixer"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.12.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ media-sound/pulseaudio[glib]
+"
+RDEPEND="${DEPEND}"