summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-01 00:00:06 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-01 00:07:06 +0200
commit9ce1585f068305ff2825bc479320d5735cfb47a2 (patch)
treeef38ebacc3beebafa51be82a53c6157172008f1f /media-sound/pianobooster
parentdev-cpp/eigen: Port SLOT=2 ebuild to EAPI 6 (diff)
downloadgentoo-9ce1585f068305ff2825bc479320d5735cfb47a2.tar.gz
gentoo-9ce1585f068305ff2825bc479320d5735cfb47a2.tar.bz2
gentoo-9ce1585f068305ff2825bc479320d5735cfb47a2.zip
media-sound/pianobooster: Port to EAPI 6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-sound/pianobooster')
-rw-r--r--media-sound/pianobooster/files/pianobooster-0.6.4b-cmake.patch4
-rw-r--r--media-sound/pianobooster/files/pianobooster-0.6.4b-gcc47.patch4
-rw-r--r--media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch4
-rw-r--r--media-sound/pianobooster/pianobooster-0.6.4b.ebuild13
4 files changed, 12 insertions, 13 deletions
diff --git a/media-sound/pianobooster/files/pianobooster-0.6.4b-cmake.patch b/media-sound/pianobooster/files/pianobooster-0.6.4b-cmake.patch
index 8cdd8738e2b3..6808c77d6e61 100644
--- a/media-sound/pianobooster/files/pianobooster-0.6.4b-cmake.patch
+++ b/media-sound/pianobooster/files/pianobooster-0.6.4b-cmake.patch
@@ -1,5 +1,5 @@
---- pianobooster-src-0.6.4b/src/CMakeLists.txt.orig
-+++ pianobooster-src-0.6.4b/src/CMakeLists.txt
+--- a/CMakeLists.txt.orig
++++ b/CMakeLists.txt
@@ -2,12 +2,6 @@
# for the debug build type cmake -DCMAKE_BUILD_TYPE=Debug
SET(CMAKE_BUILD_TYPE Release)
diff --git a/media-sound/pianobooster/files/pianobooster-0.6.4b-gcc47.patch b/media-sound/pianobooster/files/pianobooster-0.6.4b-gcc47.patch
index 2b1b28c5a849..101809716d33 100644
--- a/media-sound/pianobooster/files/pianobooster-0.6.4b-gcc47.patch
+++ b/media-sound/pianobooster/files/pianobooster-0.6.4b-gcc47.patch
@@ -1,5 +1,5 @@
---- pianobooster-src-0.6.4b/src/CMakeLists.txt.orig 2013-04-06 10:48:02.469532914 -0700
-+++ pianobooster-src-0.6.4b/src/CMakeLists.txt 2013-04-06 10:48:12.989532445 -0700
+--- a/CMakeLists.txt.orig 2013-04-06 10:48:02.469532914 -0700
++++ b/CMakeLists.txt 2013-04-06 10:48:12.989532445 -0700
@@ -203,8 +203,6 @@
${PIANOBOOSTER_UI_HDRS} )
ENDIF(WIN32)
diff --git a/media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch b/media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch
index 37720e534a3d..c462ca016aa3 100644
--- a/media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch
+++ b/media-sound/pianobooster/files/pianobooster-0.6.4b-underlinking.patch
@@ -2,8 +2,8 @@ Fix build failure caused by underlinking.
Gentoo-bug: 369697
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -57,6 +57,8 @@
#IF(ALSA_FOUND)
ADD_DEFINITIONS(-D__LINUX_ALSASEQ__)
diff --git a/media-sound/pianobooster/pianobooster-0.6.4b.ebuild b/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
index 5b72ba44adb1..ca211b2aa50a 100644
--- a/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
+++ b/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
inherit cmake-utils
MY_P=${PN}-src-${PV}
+
DESCRIPTION="A MIDI file player that teaches how to play the piano"
HOMEPAGE="http://pianobooster.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
@@ -23,20 +24,18 @@ DEPEND="fluidsynth? ( media-sound/fluidsynth )
dev-qt/qtopengl:4"
RDEPEND="${DEPEND}"
-DOCS="ReleaseNote.txt ../README.txt"
-
PATCHES=(
"${FILESDIR}"/${P}-cmake.patch
"${FILESDIR}"/${P}-gcc47.patch
"${FILESDIR}"/${P}-underlinking.patch
)
+DOCS=( ReleaseNote.txt ../README.txt )
S=${WORKDIR}/${MY_P}/src
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_use fluidsynth)
+ local mycmakeargs=(
+ -DUSE_FLUIDSYNTH=$(usex fluidsynth)
)
-
cmake-utils_src_configure
}