summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/pitchtune
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/pitchtune')
-rw-r--r--media-sound/pitchtune/Manifest1
-rw-r--r--media-sound/pitchtune/metadata.xml8
-rw-r--r--media-sound/pitchtune/pitchtune-0.0.4.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/pitchtune/Manifest b/media-sound/pitchtune/Manifest
new file mode 100644
index 000000000000..fa4a97b1a108
--- /dev/null
+++ b/media-sound/pitchtune/Manifest
@@ -0,0 +1 @@
+DIST pitchtune-0.0.4.tar.gz 163348 SHA256 f6e81b0aa1cfafc8678527b3ef8e8e4f3b2414f591629b7f51853dc9e27c9299
diff --git a/media-sound/pitchtune/metadata.xml b/media-sound/pitchtune/metadata.xml
new file mode 100644
index 000000000000..ce1975285068
--- /dev/null
+++ b/media-sound/pitchtune/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">pitchtune</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/pitchtune/pitchtune-0.0.4.ebuild b/media-sound/pitchtune/pitchtune-0.0.4.ebuild
new file mode 100644
index 000000000000..9f918ee89ae9
--- /dev/null
+++ b/media-sound/pitchtune/pitchtune-0.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Precise Instrument Tweaking for Crispy Harmony - tuner"
+HOMEPAGE="http://sourceforge.net/projects/pitchtune/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon pixmaps/${PN}.xpm
+ make_desktop_entry ${PN} Pitchtune
+ dodoc AUTHORS README REQUIRED TODO
+}